Mazda 6 Forums banner

21 - 31 of 31 Posts

·
Registered
Joined
·
12 Posts
Hi,

The cable can be bought on ebay (dont get the overpriced metra/axxess one) and the firmware would be from the axxess website I beleive.

If you check all posts by the user neil201 he managed to get the kit working correctly on a UK car. You will have to sift through various threads to find out how. His posts below:

http://forum.mazda6club.com/search.php?searchid=1102538

Good luck.
Thanks! :)

For anyone wondering, the thread referenced is as follows:
http://forum.mazda6club.com/car-electronics/190507-finally.html

I'm curious as to whether it'd work for me, though, as I have a Metra 99-7503 rather than the 7507. :(

I'm going to buy a cable online and hope for the best, nonetheless -- I can get a cable for < ~ $10 and mod it so that it *should* work; so there's no real loss if it doesn't work. :D

I would modify it as follows:
http://www.clubfrontier.org/forums/...ve-metra-usb-cab-programming-cable-5-a-79367/

Will keep you guys posted.

edit: FUDGE! Apparently the cable mentioned in that link is NOT able to update metra kits. I bought mine elsewhere (I wanted it quick, so paid a little extra and grabbed a generic one from Australia (I'm from Melbourne, AU) based on the PL2303HX), so hopefully mine works! If not, it won't be completely useless, as I'll use it for other things I may need to program in the future. :)

For the record, I purchased this adapter:
http://www.ebay.com.au/itm/19074963...X:IT&_trksid=p3984.m1497.l2649#ht_3986wt_1271

(I know it's a bit more expensive than the ones from HK, but I want it asap, so I'm happy to pay that little bit more.)
 

·
Registered
Joined
·
7 Posts
Just got this from Metra.

"There is a deviation in the communication protocol between the climate system and the OE display from models made in North/ South America and Japan.Our NEW Double din application 99-7523S* should have this sorted out when released.ETA is proposed for JUNE."

Doesn't seem like they are working on a firmware update for Mazda 6 EU/AU on the current system.. :/
 

·
Registered
Joined
·
12 Posts
Just tried this.
The USB Bootloader app that ships with WebXXpress can't detect the device. Damn. :(

Looks like I'll be waiting out for the new metra kit!
I've been incredibly busy, and so haven't been able to try it. Sorry.

The dash kit you linked above appears to a metra kit, so I'm not sure if it will work. I'd try it, but I can't afford it right now --- anyone able to test it?
 

·
Registered
Joined
·
2 Posts

Hi there, I just signed up here to let you know I succeeded in installing this kit in my 2005 6er (european Version). Everything works as it should except the clock now running in 12hrs-mode. Didn't yet find out if there's a way to change that but I can live with it. :D
 

·
Registered
Joined
·
13 Posts
I have a different looking Metra kit than the OP. But I have the same problem except the long skinny wire is plugged in. Plug and unplug produces a 0(degrees)F then it goes blank. Plus the AC turns on at start sometimes. (I blew a fuse, number 13 on interior, the manual says it is a 5 but there was a 10 there so I put a 5, original owner had usb and aux installed if that matters) ALSO hazards and other buttons do not work or at least the indicator lights don’t, except A/C, that does work but still not it’s indicator light, only the lower knobs work but no AC display. Appreciate any help
240436
240437
 
21 - 31 of 31 Posts
Top