Mazda 6 Forums banner
81 - 100 of 145 Posts

·
Registered
Joined
·
88 Posts
Thanks so much for this write up Vashthestampede!!! I installed mine today. Took about an hour, most of the time spent drilling the hole for the top cubby. Love it!

 

·
Registered
Joined
·
66 Posts
This has to be the single best audio upgrade you can do! I have a Droid X with over 600 tracks on it. I also downloaded the Power Amp app which has a pre amp and eq section with seperate treble, bass and volume control. Even without the bose system feels like therse a small subwoofer and amps in my car. Xcarlink is must buy!
 

·
Registered
Joined
·
6 Posts
I products

Several questions.
1. I own an 07 speed 6 with the factory radio/6 cd changer and Sirrius radio. Am I understanding it clearly that the xcarlink will not work with my radio unless I disable the Sirrius or cd changer?

2. Is a grom the cable used to plug in the I product to the car radio?

3. Is there a way to just hook up a 3.5mm cable tomplaynthrough the radioand is the hook up basically the same as this?

What the heck purpose does the media button do?
 

·
Registered
Joined
·
4 Posts
I am also getting noise through the tweeters with the Bose system when no music is playing, tried it with both a 3G iPod classic (physical drive) and a 3G nano (solid state HD). The noises that come through with the physical drive are different than the SS drive of the nano. Tried unplugging the 1/8" cable to reduce noise pickup and no luck.

It is not super loud, and can only be detected if the volume is above 10.

I have another car with an Alpine HU integrated with an iPod and there is absolutely no noise/feedback through the tweeters at any volume level.

Perhaps the Xcarlink needs some refinement, or does anyone have a solution to fix the noise/feedback problem?
 

·
Registered
Joined
·
269 Posts
I also have a MazdaSpeed6 and wanted to know if this walk through will be the same for me?
My car is manual transmission and from what I've noticed, everyone on here have been doing this on Auto's. Would I need to remove my shifter knob?

Also, I have the Bose...

Any sugestions would be much appreciated! BTW, great write up!
 

·
Registered
Joined
·
2,580 Posts
I also have a MazdaSpeed6 and wanted to know if this walk through will be the same for me?
My car is manual transmission and from what I've noticed, everyone on here have been doing this on Auto's. Would I need to remove my shifter knob?

Also, I have the Bose...

Any sugestions would be much appreciated! BTW, great write up!
Yup. Remove the shifter knob and start at the cup holders and work your way up. Just follow the directions step by step and you should be just fine.
 

·
Registered
Joined
·
269 Posts
Yup. Remove the shifter knob and start at the cup holders and work your way up. Just follow the directions step by step and you should be just fine.
Great, thanks! Does the manual shifter knob unscrew as well? I'm sure I can do some searches to find the answer but thought I would ask...
 

·
Registered
Joined
·
2,580 Posts
Great, thanks! Does the manual shifter knob unscrew as well? I'm sure I can do some searches to find the answer but thought I would ask...
Yup, screws right out.
 
  • Like
Reactions: JDspeed6

·
Registered
Joined
·
43 Posts
How has the XcarLink held up over time? I had the dealer install the "official" Mazda adapter in 2010 when I got my car and it just broke :mad:. Has anyone had issues with the product? I would hate to put yet another $150 into trying to play my iPod in the car only to have it randomly break in another year. Also, any experience with the Bluetooth add-on?
 

·
Registered
Joined
·
583 Posts
I bought mine used & I've had it for over a year. Are you sure it didn't disconnect in the back of the head unit or wires got frailed or sliced from the interior trim?
 

·
Registered
Joined
·
44 Posts
Discussion Starter · #93 ·
How has the XcarLink held up over time? I had the dealer install the "official" Mazda adapter in 2010 when I got my car and it just broke :mad:. Has anyone had issues with the product? I would hate to put yet another $150 into trying to play my iPod in the car only to have it randomly break in another year. Also, any experience with the Bluetooth add-on?
Since I did the write up it's worked flawlessly since the install. She actually just said to me the other day how much she loves having it.

I'm happy to see the write up is still helping everyone!! :D
 

·
Registered
Joined
·
43 Posts
I just looked behind the glovebox and everything there appears correct. The setup seems identical to the xCarLink's with a box splitting the line between the head unit and the ipod adapter piece. I tried unplugging and re-plugging the ipod line which didnt help. If i'm feeling adventurous I may try pulling the dash apart and checking the head connection. The cord is actually wedged between stuff so if it came out it wouldn't have been by being pulled. Is the connector loose back there, or does it snap into place?

You'd be surprised how much you miss the capability once it's gone!
 

·
Registered
Joined
·
231 Posts
With this great write-up, the whole installation took me a whopping 15 minutes, and damn do I suck at installation stuff :) I've left it in glove box, felt more convenient for me.

Everything works perfectly, though I hate the fact that it only supports 6 folders with 99 songs each and no subfolders (got the sd/usb version).
 

·
Registered
Joined
·
2 Posts
How has the XcarLink held up over time? I had the dealer install the "official" Mazda adapter in 2010 when I got my car and it just broke :mad:. Has anyone had issues with the product? I would hate to put yet another $150 into trying to play my iPod in the car only to have it randomly break in another year. Also, any experience with the Bluetooth add-on?
I've had my IPod version installed for about a year and it has worked great...until recently. It seems one of the connections or wires into the IPod connector has broken as I have to keep the cable curled in a certain position to maintain stereo sound. Other than that...it's been great!
 

·
Registered
Joined
·
5 Posts
Seen a few questions regarding this, but haven't noticed a response..

Does the Xcarlink prevent the 6CD multichanger from working?

I was really hoping to have both (I am greedy, yes)
 

·
Registered
Joined
·
23 Posts
Got around to attempting my install again after reading more on how to use it (read: push CD twice, not just once). Went as far as to pull the radio apart for the jumper mod but didn't need it. Had tried installing before and I guess the system didn't recognize it for some reason.

I bought the Xcarlink adapter with the bluetooth option. I figure the install is well documented but no one really documented what to do with the bluetooth part of the kit, so I put a video up on youtube. Feel free to check it out.

link: Mazda6 Xcarlink Bluetooth routing - YouTube
 

·
Registered
Joined
·
23 Posts
Seen a few questions regarding this, but haven't noticed a response..

Does the Xcarlink prevent the 6CD multichanger from working?

I was really hoping to have both (I am greedy, yes)
FWIW I have a single disc player and I can still use it...just have to tap the CD button once to switch it back. Seems to be ok! I figure since the CD selection controls are separate in that state the kit shouldn't affect it's operation.
 

·
Registered
Joined
·
34 Posts
Many thinks to the OP that originally posted the directions. The only tip I can provide is that if you drop the brass screw from behind the radio, it often falls against the inside of the panel goes along the floor. You might be able to pull the bottom end of that panel out slightly and get the screw back.

Aside from that, I'm getting some static/feedback with my iPhone 4 using the iPhone plug. Not a lot, but enough to notice when I'm playing anything through the phone. I've gone through and made sure all of the wires are secure but I can't seem to find a way to eliminate it. I just submitted a help ticket through RPM, but I was wondering if anyone had ant solutions for the issue.
 
81 - 100 of 145 Posts
Top