Mazda 6 Forums banner

1 - 13 of 13 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1
On my sons 2005 Mazda 6 the wipers come on with the turn signals. Do we have a bad computer somewhere?
 

·
Registered
Joined
·
7 Posts
Discussion Starter #2
Looking further if the head lights are on and you try and use a turn signal the hazards come on with the wipers.
 

·
Premium Member
Joined
·
561 Posts
2005, I'd guess it's probably not a computer issue. More likely there's a wiring/electrical fault somewhere (bad ground?) that's allowing current to cross over and energize what should be isolated systems.

I'm not familiar with the 2005 specifically, but the fault might be in the steering column mounted control stalk or related harness - that's one place I can think where systems like wipers, headlights, and turn signals are often in proximity, electrically speaking.

Alternatively, was the vehicle recently in an accident or otherwise experience any kind of front-end damage, maybe that you don't know about? A faulty front-end electrical repair might explain the hazards, turn signals, and headlights but it's more difficult to imagine the wipers in that scenario.

Double check the fuse/relay panels to make sure something wasn't done to "fix" a broken fuse by jumpering a circuit, maybe improperly.
 

·
Registered
Joined
·
7 Posts
Discussion Starter #4
Thanks for the reply. We just bought the car and the car fax report didn't mention any accidents and there's nothing aftermarket in the car. Our family mechanic said to replace the multifunction switch aka turn signal switch. I've ordered one and when it arrives I'm going to install it. Ill post again after to let you know if it helps. I guess I could end up replacing the wiper stalk as well.
 

·
Registered
Joined
·
7 Posts
Discussion Starter #5
So I replaced the turn signal stalk and no change. What's weird is its intermittent. Where else can I look for this fault?
 

·
Registered
Joined
·
28 Posts
Crazy issue - Wipers come on with hazzards and headlights

So I replaced the turn signal stalk and no change. What's weird is its intermittent. Where else can I look for this fault?
So I am having this problem right now with my '04 @175K miles. I'm curious if you ever figured out the solution.

I have gone over all the fuses, pulled all the relays from the main fuse box, checked the wiring harness at the ABS pump (the traction control light comes on too along with the battery and other lights) It's a friggin nightmare.
 

·
Registered
Joined
·
1 Posts
I noticed this is an old post but did anyone find a sloution to the wiper problem on the 04 madza 6 ?? I to purchased one recently for my kid, I've changed out the turnsignal switch to no avail, wondering if the wiper switch should be next?? Help if you can... thanks
 

·
Registered
Joined
·
1 Posts
I noticed this is an old post but did anyone find a sloution to the wiper problem on the 04 madza 6 ?? I to purchased one recently for my kid, I've changed out the turnsignal switch to no avail, wondering if the wiper switch should be next?? Help if you can... thanks

I got a car that to sell could not figure it out looked at all these post nothing was thinking body control mod but I also had a problem with I thought was fan control mod at same time no fans no heat fan no ac fan was body ground under air boxcleaned up worked fans and heat fan them it stoped when I had everthing together wiggled worked took for drive turnwhen I turned on signal wipers and haz cam on what in the world I was thinking was searching allover on this post nothing was just about to rare apart kick panel and j thought maybe that ground yep the 5 or 4 wire ground under air box controls all of them options with ground open up pull on piece that Bolts to body poped out Was all corroded it looked to me as to be copper or bronze on the inside fixed all my problems
 
1 - 13 of 13 Posts
Top