Mazda 6 Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
94 Posts
Discussion Starter #1
I just picked up my new '06 black speed 6 today. This is my first manual trans car. I'm not having too much of a hard time getting her rolling. :drive:

My question is that I am noticing a distinct odor of oil burning. Is this my clutch from practicing dead stop starts too much or is it just engine oil smell from being new?
 

·
Registered
Joined
·
113 Posts
I just picked up my new '06 black speed 6 today. This is my first manual trans car. I'm not having too much of a hard time getting her rolling. :drive:

My question is that I am noticing a distinct odor of oil burning. Is this my clutch from practicing dead stop starts too much or is it just engine oil smell from being new?
[/b]
May be this
http://forum.mazda6club.com/index.php?show...46&hl=smell

Mine was also there for a while but went away. Take it easy on the launches :) :drive:
 

·
Registered
Joined
·
94 Posts
Discussion Starter #3
If anything I'm not giving it enough gas when lauching. I'm not doing any clutch dumps. My dad says that it could be the turbo. We will see as time goes on. Thanks for the info.
 

·
Registered
Joined
·
1,427 Posts
It will go away, trust me
[/b]

yeah i got my car with 2000 miles on it, and for the first 700 miles i drove it the smell was noticeable. not bad, but there. i figured it was the clutch, but im not revving it hard off the line or anything. its starting to fade, ive driven 800 miles on it so far.
 
1 - 5 of 5 Posts
Top