Mazda 6 Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
898 Posts
Discussion Starter #1
Well, I've done the unthinkable and run my car for 8,000 kms (5,000 miles) on a single oil change. A couple of months ago, I told the dealer about some vibration, and he replaced an engine mount, along with the regular oil change, and it was all gone. A few weeks later (after the car had run up some 5,000 kms on that oil) the vibes began to creep back. I thought about calling up the dealer to tell him that there might be another bad mount, but last night I hit some extra cash and decided to change the oil, and now the engine runs even smoother than the day I took delivery of the car! I should do this more often :)
 

·
Premium Member
Joined
·
4,053 Posts
What oil did you use?

I changed my oil at 7500 miles and never have problems.
 

·
Registered
Joined
·
898 Posts
Discussion Starter #3
Castrol GTX 20-50.
For some reason, the dealer had used 10-30 every time without telling me, but I told specifically tell them to use a higher grade whenever I take it over for a major service now.
 

·
Premium Member
Joined
·
4,053 Posts
20-50 and 10-30???

I just noticed that you're in Saudi Arabia. What did the car manual tell you to use? Those are thick oil. I don't know if the mazda there is different than here. But overhere, we use 5w-20.
 

·
Registered
Joined
·
898 Posts
Discussion Starter #6
Yup. When temperatures soar to 45 C and you cruise at 160km/h with the AC full on, you'd want your oil to be that thick :)
besides, the manual recommends 20-50 for our temperature range, which made me wonder why the dealer used 10-30 on my car for all that time.
 

·
Registered
2017 MZ6 GT Jet Black Mica
Joined
·
3,569 Posts
I've only ever had my oil changed at the dealership since I had the car. I do it every 5000 miles though. I did it at 3700, 8500, and 13,300 so far.
 
1 - 7 of 7 Posts
Top