Mazda 6 Forums banner

1 - 10 of 10 Posts

·
Registered
Joined
·
345 Posts
Discussion Starter #1
okay so i have a wadafak question

Every time I drive my 6 like through semi deep water I mean if its a low part that collected water at an intersection that comes up probably about 6 inches deep its not like a river but just deep enough to make a HUGE splash on either side, anyway every time I do this the next 2 to 4 times I shift every time I put it into neutral and start to let off the clutch it screeches! like LOUD and then stops then when I shift again it does the same thing for maybe the next 2 to 3 shifts.

And no to anyone who has posted on my thread separation anxiety i do not have my car back I am still at college I'm just wondering while I'm here bored out of my mind with no car :(
 

·
Registered
Joined
·
339 Posts
Drive belts getting wet and slipping???
 

·
Registered
Joined
·
345 Posts
Discussion Starter #4
It stops after 2 or 3 shifts but next puddle it does the same thing. It pisses me off though its annoying as shit. Mine's an 05 v6 mtx does anyone have a shot of their 05 v6 on a lift so I can see if I'm missing panels under the car cause it just seems like something should block water from getting up there.
 

·
Registered
Joined
·
345 Posts
Discussion Starter #6
Im sorry guys I only know what the underside of my car looks like But i don't have it with me since im at college I need a picture, obviously if you don't have one don't take one for my sake. But if the opportunity presents itself please do.
 

·
Registered
Joined
·
345 Posts
Discussion Starter #7
Bump I am still looking for a pic of the underside of an 05 or similair year underbody so I can see if I have all the proper plastic shields and guards attached under when I go home this weekend.
 

·
Registered
Joined
·
5,733 Posts
well that depends. lol. some 05's had the full under tray, and other's didnt. so someone posting pics wont mean crap on how yours was stock. but the full under tray shouldnt matter since mazda decided only to put them on 1/4 of the 6's they made if even that many
 

·
Registered
Joined
·
345 Posts
Discussion Starter #9
It just feels like the cause would be water getting into my clutch cause I mean these were fairly deep "puddles" but they were only about this wide so its not like it got wet consistently just a big splash whenever I went across perpendicularlly one of these. so I think water splashed up into my clutch some how and I just thought maybe I was missing some sort of guard against that. I mean it just seems common sense to me.
 

·
Registered
Joined
·
345 Posts
Discussion Starter #10
btw thats the best pic I could find to represent what the water was like just imagine one of those streams every intersection. But its not like I was running paralell to it.
 
1 - 10 of 10 Posts
Top