Mazda 6 Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Hi hopefully someone can help

I have a Mazda 6 2015 2.2 skyactiv diesel.

I keep error on the dashboard saying vehicle system malfunction but give no further information does anybody have any ideas

thanks
 

·
Registered
Joined
·
2 Posts
Nothing error code now. at first SCBS sensor fault message was - I cleaned the windscreen, reset the tyre press. that was ok only one week. Oil,Engine and SCBS sign started to light after 1 week. The oil level was too high but I checked oil wasn`t mixed with cooler water . So I changed the oil , all filters and cleaned the air sensor because the reader showed Mass Air Sensor error.It was successful and I was happy till now . Today the Vehicle System Mailfunction is the message on display but the reader does not find any error.
 

·
Registered
Joined
·
1 Posts
Nothing error code now. at first SCBS sensor fault message was - I cleaned the windscreen, reset the tyre press. that was ok only one week. Oil,Engine and SCBS sign started to light after 1 week. The oil level was too high but I checked oil wasn`t mixed with cooler water . So I changed the oil , all filters and cleaned the air sensor because the reader showed Mass Air Sensor error.It was successful and I was happy till now . Today the Vehicle System Mailfunction is the message on display but the reader does not find any error.
I have exactly the same issue, Vehicle System Mailfunction message appeared but reader does not give any error. Does anyone have any idea where to look for a fault or how to clear this message. Help would be much appreciated.
 

·
Registered
Joined
·
1 Posts
Hi, I have the same issue, first oil light, fixed with full service and oil change, then SCBS light, that went, then DPF soot level too high, fixed by keeping revs above 3000 for 10 minute drive and DPF cleaner additive.

Now we have the Vehicle System Malfunction message which is a little intermittent and usually comes on 5-10 mins into journey.
Tried OBD coder reader whilst warning light was on and It did not pick any stores errors (or any live errors). Tried clearing message using tool which got rid of the warning...until the next journey.
Any ideas on what the problem could be would be much appreciated, not yet had it checked out as it drives fine etc and was just serviced by Mazda so I would assume they would notice any obvious issues.
 
1 - 6 of 6 Posts
Top