Mazda 6 Forums banner
1 - 18 of 18 Posts

·
Registered
Joined
·
42 Posts
Discussion Starter · #1 ·
So my speed6 doesnt start.

I jumped it, let it ran for ~30 minutes, let it sit for and hour, then tried to start it and it wouldnt turn over.

I do have an 2ch amp and sub, but I pulled the fuse after running it for the hour.

I just took it to Advanced auto and they hooked it up to their tester and it is putting out about 50A peak when I hold it at 2k RPM, which he says is low and it should be 75-100 A Peak.

I fear going to the dealer becaue they will see the stereo hookup, the Mac Mini hookup, and probably try to re-flash it, ruining my fun forever.

My question is am I on the right track to assume alternator problems? I just have the stock battery, but that should last longer then a year. I just hate dealing with the dealer.

"I have a bad feeling about this"

thanks

joe
 

·
Registered
Joined
·
2,426 Posts
Why do you have a mac mini hooked up in your car?
 

·
Registered
Joined
·
2,426 Posts
Are you using the NAV monitor or an aftermarket one?
 

·
Registered
Joined
·
2,426 Posts
Where is it mounted? Do you have pictures?
 

·
Registered
Joined
·
42 Posts
Discussion Starter · #7 ·
its in the cubby hole above the stereo unit. fits rather nice actually, just have to make a support rail for it so I can pop it up then put it away for security.

I have the mac in the glovebox, that fits rather nice in there too. I also have the IPOD adapter from RPM that runs into the middle console.

I dont have a pic right now, that I am aware of, plus I took the screen out because it is cold as hell outside.
 

·
Registered
Joined
·
1,396 Posts
So my speed6 doesnt start.

I jumped it, let it ran for ~30 minutes, let it sit for and hour, then tried to start it and it wouldnt turn over.

I do have an 2ch amp and sub, but I pulled the fuse after running it for the hour.

I just took it to Advanced auto and they hooked it up to their tester and it is putting out about 50A peak when I hold it at 2k RPM, which he says is low and it should be 75-100 A Peak.

I fear going to the dealer becaue they will see the stereo hookup, the Mac Mini hookup, and probably try to re-flash it, ruining my fun forever.

My question is am I on the right track to assume alternator problems? I just have the stock battery, but that should last longer then a year. I just hate dealing with the dealer.

"I have a bad feeling about this"

thanks

joe[/b]
Most modern cars have charging systems designed to hit peak output somewhere near the normal operating range of the motor. I'd figure that to be between 2750~3500 rpm with our close gearing. How often do you drive around at 2000 rpm? I bet you'd be alot closer to the 90 amp rating at 3000 rpm? More than likely your alt is fine and your stock battery is toast--they are crap batteries and should be replaced ASAP...

Get a good battery first, and then if your still having problems check for any current draw after you shut the car off. Go to the dealer only as a last resort because they can (and probably will) blame any alternator issues on the extra current draw from your amps..
 

·
Premium Member
Joined
·
3,070 Posts
What is so bad about the stock batteries? You are saying they need to be replaced in a year or less?
 

·
Registered
Joined
·
1,396 Posts
What is so bad about the stock batteries? You are saying they need to be replaced in a year or less?[/b]
Most OEM batteries are the smallest cheapest part that will start the car. Now, Mazda or any OEM isn't going to use a part that's unsuitable for the application, but amps and other electrical accessories can draw alot of current and put alot of extra stress on the battery. The stock battery is just not up to this extra load and will fail quickly...Better to replace it before it leaves you stranded somewhere..
 

·
Registered
Joined
·
123 Posts
you should get a cap, i have blown up many alternators, i put two caps in line with the amps they work great, never had problem after installing them, also put in a separate alternator gauge to see what is going on with your amps on alt when stereo is pounding. hops this helps peeps out in saving your alternators.
 

Attachments

·
Registered
Joined
·
10 Posts
So my speed6 doesnt start.

I jumped it, let it ran for ~30 minutes, let it sit for and hour, then tried to start it and it wouldnt turn over.

I do have an 2ch amp and sub, but I pulled the fuse after running it for the hour.

I just took it to Advanced auto and they hooked it up to their tester and it is putting out about 50A peak when I hold it at 2k RPM, which he says is low and it should be 75-100 A Peak.

I fear going to the dealer becaue they will see the stereo hookup, the Mac Mini hookup, and probably try to re-flash it, ruining my fun forever.

My question is am I on the right track to assume alternator problems? I just have the stock battery, but that should last longer then a year. I just hate dealing with the dealer.

"I have a bad feeling about this"

thanks

joe[/b]
The quick and easy way to diag an alternator is start the engine and disconnect the negative terminal at the battery. If your car still runs then it is pushing enough amperage to power the powertrain. With the terminal still disconnected, turn on your headlights and she what happens. If it still runs your alternator is good, if it stall you got a bad alternator.
 

·
Registered
Joined
·
42 Posts
Discussion Starter · #13 ·
you should get a cap, i have blown up many alternators, i put two caps in line with the amps they work great, never had problem after installing them, also put in a separate alternator gauge to see what is going on with your amps on alt when stereo is pounding. hops this helps peeps out in saving your alternators.[/b]
I have a 1/2 Farad cap already on it.

The real test will be this morning when I try to start it after a night of sitting
 

·
Registered
Joined
·
273 Posts
From the description I'd have to lean towards battery. A proper full test will take about an hour. If you have a multi-meter you can get an easy handle on what the alt is putting out but if the battery has been drawn down hard it just won't store any more.

-Rich
 

·
Registered
Joined
·
42 Posts
Discussion Starter · #15 ·
so last night the car started fine 30 minutes and 60 minutes after I got back from Advanced Auto.

This morning it started just fine too.

And also after I got home from work approximately 10 hours later.

It was a lot warmer out today then it has been in the past few weeks, so that might have helped a lot too, I am not sure.

Does this point any more fingers?

Its starting to drive me nuts.
 

·
Registered
Joined
·
3,431 Posts
I had a battery problem with mine for almost a year, and SEVERAL trips to the dealership. Car kept dieing, needing jumped etc. They checked my alternator and it was fine, and kept replacing/recharging my stock battery which did no good. One time it was SO dead I had to have mazda roadside come get it on a flatbed from my driveway. I finally said F the dealership and went and bought a red top optima battery, no problems since, even with adding a system in the trunk.

I don't know what year your 6 is, but mine is an '05.. I used to have an '03, and the alternator DID go out at about 25k miles once, but the recharge system light was on the dash (battery symbol) and it was very obvious what had happened.
 

·
Registered
Joined
·
42 Posts
Discussion Starter · #17 ·
the battery light did come on on my last car when the alternator went on it. not on my speed 6 (its a 2006). Ive had it a year last december. I've been pricing red tops. They had them at Advanced Auto for 144 after a battery swap or 188 for a yellow. anywhere else that may be a better deal?

joe
 

·
Registered
Joined
·
42 Posts
Discussion Starter · #18 ·
I brought my car in and they checked it out, and found it was the battery. replaced, I paid 50/50 since it was over 12 months old. hopefully this is all.

They sold me a mazda "high performance" battery. JDM. woo, hopefully it lasts for a couple years.

joe
 
1 - 18 of 18 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top