Mazda 6 Forums banner
1 - 18 of 18 Posts

·
Registered
Joined
·
37 Posts
Discussion Starter · #1 ·
I have a Mazda 6 2017 Grand Touring that was front-ended, it wasn't deep but the airbox was broken and the fuse box pushed. After I reseated everything and replaced most damaged components and removed the others. I just noticed that with my OBD2 Scanner I find error code U0155, it's an ELM327. No other error codes just that one, on my instrument cluster there are a few lights including tire pressure, check engine, power steering malfunction, and the coolant temperature not working.
So far I checked all fuses in the fuse box, all of them work. Not sure about the relays however, I reseated connections on the ECU and the gauge cluster, so far only a few things work on the gauge cluster like the speedometer, rev counter, and a few other warning lights like the safety system which I toggled on and off successfully by disconnecting and reconnecting my seatbelt sensor.
I have a multimeter but can't access the wiring diagrams due to them requiring adobe flash, and I'm really not sure where to start looking and what to check.
Any help would be greatly appreciated.
(btw to double-check that my sensor isn't bad I was able to read coolant temperature with my phone connected to the ELM327)
 

·
Registered
Joined
·
4,248 Posts
Install & Enable flash?!? All I have is a multimeter and an ELM327 bluetooth scanner, I am not very familiar with stuff...
:cautious::cautious::cautious: Usually when someone says something you dont understand, it helps to look that up to try an educate yourself. I pointed you in the right direction... but sure... let me break it down for you :rolleyes:.

You said you cant read the wiring diagrams cause they require (Adobe) Flash. I know as well as many others, Flash was discontinued in browsers on Dec 31st. You can for example, install an older version of Firefox and then you can use Flash and read the wiring diagrams...

You have an ELM327... if you looked up Forscan, youd see its "free" and requires an ELM327 to work. Since you have an ELM327, you either have a phone or tablet or laptop meaning you can use Forscan on it at well.

Between my CAN HI and CAN LOW I am getting 63 ohms which seems fine
WTH does that have to do with anything?
 

·
Registered
Joined
·
37 Posts
Discussion Starter · #6 ·
:cautious::cautious::cautious: Usually when someone says something you dont understand, it helps to look that up to try an educate yourself. I pointed you in the right direction... but sure... let me break it down for you :rolleyes:.

You said you cant read the wiring diagrams cause they require (Adobe) Flash. I know as well as many others, Flash was discontinued in browsers on Dec 31st. You can for example, install an older version of Firefox and then you can use Flash and read the wiring diagrams...

You have an ELM327... if you looked up Forscan, youd see its "free" and requires an ELM327 to work. Since you have an ELM327, you either have a phone or tablet or laptop meaning you can use Forscan on it at well.


WTH does that have to do with anything?
Yes after you said that I looked into forscan, thank you so much for the insight, I am buying a new ELM327 since mine turned out to be a bad clone. Before I was using Torque Pro lol. Also thank you for the advice about the old firefox version, I used it but the diagrams didnt help much lol.
I mentioned the can bus because many articles I read mentioned an issue in CAN bus can be causing the error to appear.
Once my new ELM327 arrives I will try what you mentioned above :)
 

·
Registered
Joined
·
37 Posts
Discussion Starter · #8 · (Edited)
With the proper ELM327 Im getting U0401 on my IC and my F_BCM, what should I do?
"invalid data received from ecm/pcm A"
 

·
Registered
Joined
·
4,248 Posts
Did you reset the FBCM? If so and still getting it, its possible theres a pinched/cut wire somewhere youll have to chase down and fix.

U0401 Meaning
A Controller Area Network (CAN) is a vehicle bus standard designed to interconnect automotive devices without a host computer. Operating information and commands are exchanged among the devices. The devices have programmed information about what messages are needed to be exchanged on the serial data circuits. Some devices are constantly receiving information from other devices through serial data communication network. The invalid data Diagnostic Trouble Code (DTC) will be set when a receiving device detects a discrepancy in the information it receives from the Engine Control Module (ECM)/Powertrain Control Module (PCM) causing its integrity to be questioned.
 

·
Registered
Joined
·
37 Posts
Discussion Starter · #10 ·
Did you reset the FBCM? If so and still getting it, its possible theres a pinched/cut wire somewhere youll have to chase down and fix.

U0401 Meaning
A Controller Area Network (CAN) is a vehicle bus standard designed to interconnect automotive devices without a host computer. Operating information and commands are exchanged among the devices. The devices have programmed information about what messages are needed to be exchanged on the serial data circuits. Some devices are constantly receiving information from other devices through serial data communication network. The invalid data Diagnostic Trouble Code (DTC) will be set when a receiving device detects a discrepancy in the information it receives from the Engine Control Module (ECM)/Powertrain Control Module (PCM) causing its integrity to be questioned.
Yes I had reset the BCM, I scanned the PCM and it seemed to be operating fine.. could it be possible that the ECM has gone bad, or maybe the connections to or from it?
 

·
Registered
Joined
·
37 Posts
Discussion Starter · #12 ·
Thanks for the reply, I will inspect the wires. I know that I have my ambient air sensor disconnected, could that affect anything? Heres my forscan log if it can provide anything that I didnt mention. Ignore the airbags and saftey system warnings because Im also repairing the vehicle airbag & belt since it was in a front end collision
 

Attachments

·
Registered
Joined
·
4,248 Posts
ThIs is gonna cause a lot of issues cause its tied into so many systems on a GT, id look at it first:

===HUD_MZ DTC U023A:00-8A===
Code: U023A - Lost Communication with Forward Sensing Camera

Status:
- DTC Present at Time of Request
- Malfunction Indicator Lamp is On for this DTC

Thats in the front emblem, its either damaged or the wiring harness for it is. i honestly didnt think id find anything of value in the log, but looked at it anyway. So, id start with that. The coolant temp sensor should be in the radiator too, so that might be in the same "area" or harness for the front bumper cover. Good thinking on including it.
 

·
Registered
Joined
·
37 Posts
Discussion Starter · #14 ·
ThIs is gonna cause a lot of issues cause its tied into so many systems on a GT, id look at it first:

===HUD_MZ DTC U023A:00-8A===
Code: U023A - Lost Communication with Forward Sensing Camera

Status:
  • DTC Present at Time of Request
  • Malfunction Indicator Lamp is On for this DTC

Thats in the front emblem, its either damaged or the wiring harness for it is. i honestly didnt think id find anything of value in the log, but looked at it anyway. So, id start with that. The coolant temp sensor should be in the radiator too, so that might be in the same "area" or harness for the front bumper cover. Good thinking on including it.
Yes the entire bumper is completely removed along with the front radar, I will fix everything in the car physically and check again. Thank you
 

·
Registered
Joined
·
37 Posts
Discussion Starter · #15 ·
A
ThIs is gonna cause a lot of issues cause its tied into so many systems on a GT, id look at it first:

===HUD_MZ DTC U023A:00-8A===
Code: U023A - Lost Communication with Forward Sensing Camera

Status:
  • DTC Present at Time of Request
  • Malfunction Indicator Lamp is On for this DTC

Thats in the front emblem, its either damaged or the wiring harness for it is. i honestly didnt think id find anything of value in the log, but looked at it anyway. So, id start with that. The coolant temp sensor should be in the radiator too, so that might be in the same "area" or harness for the front bumper cover. Good thinking on including it.
Are you sure its in the front bumper?
Could it be just erroring since the front radar isnt connected
 

·
Registered
Joined
·
37 Posts
Discussion Starter · #17 ·
I connected every sensor except the cruise control radar and I am happy to report the U0155 error is gone, I believe the ambient temp one was the reason for the issue to happen. All whats left is figuring out how to reset the airbag system lol
 
1 - 18 of 18 Posts
Top