Mazda 6 Forums banner

1 - 10 of 10 Posts

·
Registered
Joined
·
672 Posts
Discussion Starter #1
Just took the MS6 into dealer for a CEL. Got it a couple weeks ago but dealer was not stressed b/c it had been running normal. Anyway, they said it was due to P2407 and said they reprogrammed it per TSB01-037/06. No mods yet, only thing I've done to the car so far is the 4106E recall/reflash and airbox delete.

Paperwork says:
" Code P2407 Present in Memor[y] Reprogram PCM as per TSB01-037/06"


During the short drive between dealer and work (5-6 miles), couldn't really tell anything out of the norm. Although, merging from the slow lane from 50 to 80mph was worth about 10 minutes of giggles (but that's biz as usual with this car).

Sorry if this has been posted somewhere (did a quick search & only found stuff related to 4106E recall). Anyone know anything about this TSB? Any details out there about what it does, what it fixes etc?
 

·
Registered
Joined
·
856 Posts
Just took the MS6 into dealer for a CEL. Got it a couple weeks ago but dealer was not stressed b/c it had been running normal. Anyway, they said it was due to P2407 and said they reprogrammed it per TSB01-037/06. No mods yet, only thing I've done to the car so far is the 4106E recall/reflash and airbox delete.

Paperwork says:
" Code P2407 Present in Memor[y] Reprogram PCM as per TSB01-037/06"
During the short drive between dealer and work (5-6 miles), couldn't really tell anything out of the norm. Although, merging from the slow lane from 50 to 80mph was worth about 10 minutes of giggles (but that's biz as usual with this car).

Sorry if this has been posted somewhere (did a quick search & only found stuff related to 4106E recall). Anyone know anything about this TSB? Any details out there about what it does, what it fixes etc?
[/b]
I have not heard of this TSB.
I wonder if this is what the post 4106E flash is all about.
What is P2407, Evap leak detection?
 

·
Registered
Joined
·
1,022 Posts
It's in the same range of EVAP voltage problems. I think it's an intermittent curcuit problem with the pump code.
 

·
Registered
Joined
·
788 Posts
I have been getting the same problem, but I haven't had a chance to get it in to the dealer yet...
 

·
Registered
Joined
·
182 Posts
I experienced the same CEL at 2000 miles. When I took my car into the dealership they tested the leak detection pump, and said it was faulty. I’ve gone a little over 2000 miles now without a problem.
 

·
Registered
Joined
·
361 Posts
Funny my CEL has been on for over a week while I wait till Wed to have a new "fuel pressure sensor" installed. I wonder if Mazda knows of these problems?
 

·
Registered
Joined
·
788 Posts
I have the latest flash, so my guess is that the leak detection pump is faulty on my car as well, I just need time to get it into the dealer...
 

·
Registered
Joined
·
672 Posts
Discussion Starter #8
I have the latest flash, so my guess is that the leak detection pump is faulty on my car as well, I just need time to get it into the dealer...
[/b]
PlatinumMS6...by latest flash are you talking about 4106E (power loss recall). From what I've read, it sounds like there different versions of the 4106E reflash file but I think this TSB/flash is something different. The dealer said ths TSB was specifically for people who got the P2407 CEL. I wish someone who runs in the Mazda circles could tell us more.

50 Mile Update....
Interestingly, now that I have about 50 miles on the car, I'm pleased with whatever it fixed. Although the power loss recall smoothed out power delivery (as many have reported), it still stumbled/stuttered/hesitated in various situations, typically it was under hard acceleration. This TSB seems to have finished where the Recall left off.

In these 50 miles since TSB, I've observed:
* Car seems to just run smoother (almost too smooth - seems quieter both under throttle and at idle)
* Power delivery has smoothed even more than after recall
* No degradation in performance and maybe even a little gain (for ex. now tires chirp when launching even when DSC is ON plus I notice power transferring to the rear (dull clunk) under hard launches with DSC on
 

·
Registered
Joined
·
679 Posts
I have the stumble during a hard push but when I turn off the DSC I notice it go away....mostly second gear WOT.
 

·
Registered
Joined
·
788 Posts
thats weird, maybe THATS what my car is doing, i'll try that...after i get the light fixed tomorrow hopefully...
 
1 - 10 of 10 Posts
Top