Mazda 6 Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
1,073 Posts
Discussion Starter #1
Made it all the way to the parking lot at work through the massive dumpage of rain. Crossing a puddle in the parking lot at idle speed real slow and my car dies. I coast through the puddle, click to neutral and, CLICK! No starter.
Stop, select park, and CLICK. Engine does not turn over.

:eek: Sonofabi+¢h! I freakin' hydrolocked.

Pushed the car over to the nearest space, locked it up, and went into work thinking the worst.

I mean the engine won't turn over and we got like 12" of rain today. Hydrolock makes sense. I start the dread process of selecting which stealership is going to get my insurance company's money and trying to figure out how to get a pair of new precats added on.

A few hours later, just for grins and hahas, I turn the key again. It starts.
No CEL, no misfire....just starts.

I let it idle for 20 minutes expecting it to have a crankcase full of melted chocolate shake yuckiness. Nope, clean. Not even any frothy goo on the inside of the oil cap.

I have no idea WTF happened. I thought maybe I had swamped the starter and it had to dry out to work, but that doesn't explain why it died. If I had flooded something electrical, surely I would trip a CEL wouldn't I?

Whole event is weird. I hope I didn't goof anything up.
 

·
Registered
Joined
·
3,414 Posts
God damn it, I was about to hit "post" reply, and I accidentally backed out 3 windows to the point of no return.

Anways.... I'm glad you're engine isn't shot... you had me worried there! As for the CEL.... they can take a bit of time to register, and if the problem is corrected, they can go away on their own.

This just happened to me the other day with a CEL. I forgot to fully push this clip on the wire harness to the throttle body back on completely. When the car turned over, it took a good minute before I threw a CEL. I assumed it was "lean condition at idle" due to changing the fuel rail, and that's not a big deal. I pulled the code and it was for "APP voltage correlation problem"... I checked the throttle body, saw the clip, and pushed it forward to lock it. When I turned it back over again, the CEL went away on its own.

If I were you, I'd have the historical code pulled, as it should be stored in memory, so you can see what it was.
 
  • Like
Reactions: Spazdog

·
Registered
Joined
·
1,073 Posts
Discussion Starter #3
My state inspection runs out this month. I wonder if they'll find anything. I know that if you reset the ECU and then go for an inspection it fails you for lack of history codes.

My old boss will let me use his MT2500 scanner, but I always end up having to do something. Last time I had to pull the ECU out of one of those Lincoln "Conti-Tauruses". Pretty easy. I'm sure he'll have something harder this time like cleaning the TCM harness for an Eclipse who's owner spills a lot of coffee. (the transmission control module is under the cupholder...dumb place)
 

·
Registered
Joined
·
3,414 Posts
AFAIK, you'll fail if you throw any codes. Also, I've read that you can't reset it right before an inspection or it won't pass. I'm not 100% on that though, but someone should know. My inspection expired last month, and I went to get it inspected and 2 places wouldn't do it because I moved my OBD port... I rigged up a OBD splitter for my AP and DH, and all the damn cords were in the way. I'm going to try another shop, because it's a pita to get under there and put it back to 'stock.' My advice is do NOT let them fail you... I'd back the hell out of the shop before they put a giant "failed" sticker on.... other inpsection stations will be looking your car over with a fine tooth comb so they don't lose their license to inspect.

EDIT: That's for the MS6 anyways... but I would imagine it's the same.
 

·
Registered
Joined
·
57 Posts
There may be a pending code that didn't set the CEL.

If you clear codes it will take time for all the tests to be performed again. When an OBDII emission test is done it may come up with incomplete tests if the car isn't driven enough after clearing.
 
1 - 5 of 5 Posts
Top