Mazda 6 Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
2007 Mazda 6i. Auto. Got Reman engine, but now when mating trans, the torque converter bolts contact block. I’ve pushed the converter as far into the trans, so nothing protrudes past front of trans. As soon as I torque the trans the bolts rub. I can’t figure out why there is not enough clearance, and the flex plate is getting pushed toward the block. Had this thing apart 5 times, with no luck. Severely irritated I’m not smarter than the car.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #2
2007 Mazda 6i. Auto. Got Reman engine, but now when mating trans, the torque converter bolts contact block. I’ve pushed the converter as far into the trans, so nothing protrudes past front of trans. As soon as I torque the trans the bolts rub. I can’t figure out why there is not enough clearance, and the flex plate is getting pushed toward the block. Had this thing apart 5 times, with no luck. Severely irritated I’m not smarter than the car.
Any suggestions, however small, are appreciated.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #3
Any suggestions, however small, are appreciated.
Update: Seems the seventh time was the charm. After some online reading, ensuring the trans and block could be slid together by hand, not using the bolts to draw them up, and making sure i could move either one independently, was the winner.
Maybe this old news, but my first Ford replacement, and never had this problem with the many GM And Dodge projects.
Hope this helps someone out there.
 
1 - 3 of 3 Posts
Top