Mazda 6 Forums banner
1 - 2 of 2 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
Hey guys,
I bought a 04 mazda 6s new is now at its 20000mi mark and have been having the "thud" --actual sound coming out from the transmission while shifting (not shift shock), the notorious shift shock, sometime non-responsive throttle and also the surge for a while now. Everytime they checked, they either flashed computer or did nothing. SO after reading posts about known problem of the tranny I decided to take it in for a tranny flush. My car is stock from bottom up, and everything has been done by dealer, except wheel change. But this when I had them do the tranny flush, the guy called me up saying that my tranny fluid was low...but there was no leaks found. I asked him how can it be, he said there was "no" logical explanation. So now, two questions come to my mind. One is that could it be when the car left the factory in the very beginning the transmission was low on fluid? Maybe the guy at work had a bad day that day or they ran out of fluid? And how much damage would have been done to the tranny? I'm faced with the dilemma that the tranny might not show significant problems before the warranty is up since the problem was discovered "earlier".
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #2 ·
Ok since nobody answered me, I'll just give a quick update. I got my car back today with the tranny flush done and its shifting alot smoother so far...Wonder how long the new tranny fluids will last without the tranny cooler. But I guess having ENOUGH fluids did help! Anyways, anybody have an idea how badly damaged the tranny can be with low fluids???
 
1 - 2 of 2 Posts
Top