Mazda 6 Forums banner

1 - 11 of 11 Posts

·
Registered
Joined
·
45 Posts
Discussion Starter #1
so ive got almost 120k on my 6 and its been pretty good for me so far ... i just wanted to see if anyone out there had any advice for me ... i rescently took a code for my TSP ... and the car ran fine up until a couple of days ago ... was driving home and the check engine light came on AT light came on TCS light came on also ... i went to the mazda dealer here and they said they wanted to do a diagnostic on it for 100 dollars ... and i walked out ....my dad is a mazda mechanic and i know i have read on a couple of threads on here that im not the only one with the issue ... iw as going to replace the TSP but i cant find one ... so i was told i had to get a new throttle body ... and i saw on a few threads that cordova motorsports has optimized throttle bodys ... and i tried to contact them to see if i could get one but no respond from the emails ... and they have no number to call so im kinda skeptical about ordering one from them... any advice is much appreciated
 

·
Registered
Joined
·
11 Posts
keep us posted on how it works out. have the same problem and a local mechanic wants to charge $125 for a diagnostic, smoke-test for vacuum leaks, and a computer "relearn". after reading the forums, i'm pretty sure it's the TB but i'd hate to spend the money on replacing that if it's something else. i have the "AA" model TB, but i didn't start experiencing problems till i hit 125K...and it seems the TB issues occur at much fewer miles.

while working on the car today, i noticed i had a cracked PCV hose. replaced that today, but still show a CEL. haven't driven it long enough yet to see if it drives any differently. kinda in a pinch because i need to get a vehicle inspection this month...
 

·
Registered
Joined
·
1,610 Posts
It's a long story but it looks like my dynamic IP has ended up taking on a number that is on some big spam list, so emails are getting blocked. (I'm re-ip-ing my server now....)

Get the CEL code from autozone for free. If the CEL is because of your TB, it probably needs to be replaced. Mazda just jacked up the price on this part, so it's going to be over $400 for the V6 now!!
 

·
Registered
Joined
·
45 Posts
Discussion Starter #4
QUOTE (twowheelin @ Feb 14 2010, 04:15 PM) index.php?act=findpost&pid=1636983
It's a long story but it looks like my dynamic IP has ended up taking on a number that is on some big spam list, so emails are getting blocked. (I'm re-ip-ing my server now....)

Get the CEL code from autozone for free. If the CEL is because of your TB, it probably needs to be replaced. Mazda just jacked up the price on this part, so it's going to be over $400 for the V6 now!![/b]
Ok, so are you still modifing the throttle bodys? Or still have them for sale?
 

·
Registered
Joined
·
1,610 Posts
QUOTE (03v6m6 @ Feb 14 2010, 06:45 PM) index.php?act=findpost&pid=1637000
Ok, so are you still modifing the throttle bodys? Or still have them for sale?[/b]
Yes, everything is operating normally. Please visit the Cordova Motorsports web-site for details.

(The mail issue has been fixed... :blush: )
 

·
Registered
Joined
·
1,610 Posts
QUOTE (03v6m6 @ Feb 14 2010, 11:39 PM) index.php?act=findpost&pid=1637054
so you guys still operate? and do the throttle bodys come with everything on them i.e. the tsp and what not?[/b]
Yes. It's a complete throttle body assembly for a complete swap out of the older part. The original gasket can be re-used.
 

·
Registered
Joined
·
45 Posts
Discussion Starter #8
thanks for all the info ... i just put it on and the car runs completely differnet. i can barely feel it shift, but i can hear the rpm drop ... and it idles much smoother and the acceleration is back to normal. thanks again
 

·
Registered
Joined
·
5 Posts
So I have a 03 6s mt and i Replaced the tb with a new otb from cordova. and i noticed quiet the throttle lag and it felt like my motor mounts were going bad. so i replaced them for awr mounts and things got a little better. Now my issues are throttle lag and when i put the clutch in to start slowing down my engine almost dies and the automatic choke kicks in (or whatever kicks in) and revs back up to 1500-2000rpms then drops back to 700 idle. So I'm debating on getting the software up grade for the new throttle body for 95 bucks if its going to even do anything?
YOUR help is greatly appreciated!
 

·
Registered
Joined
·
45 Posts
Discussion Starter #10
see idk about that issue.... replacing the throttle body with the one from cordova fixed most of my issues ... i mean yea i know my trans slipps a little bit every once in a while but i have 122,000 miles on my car ... bit idk why it would do that on a maual car ... check your clutch fluid that might be one problem ... or maybe just your pedal isnt adjusted correctly if you put in a new clutch
 
1 - 11 of 11 Posts
Top