Mazda 6 Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
48 Posts
Discussion Starter #1
Last week i was on my way to school when my car suddenly lost power and the check engine light came on. The RPM’s moved between 1,000 – 1,500 and when you stepped on the gas pedal the car would not move. So I turn the car on and off the RPM where normal but the check engine light was on. When I got to the dealer the check engine light came off . So the dealer diagnosed the car and they found that the throttle body went bad.
So they replaced the throttle body and I was on my way. Two days ago same thing happed the car lost power and the rpm jumped like crazy. I dropped it off at the dealer and they told me they have to replace the wire harness of the throttle body. I dropped if off on Friday and I still don’t have the car. It is a 2005 Mazda 6 MTX v6 with 6,200 miles.
 

·
Registered
Joined
·
179 Posts
ok. hope it all gets fixed.. dont know what you want us to say... :)
[/b]
Sometimes you don't have to say anything at all. Sometimes you just have to listen.
:)

Remember that with the ladies.
 

·
Administrator
Joined
·
8,397 Posts
Sometimes you don't have to say anything at all. Sometimes you just have to listen.
Remember that with the ladies.
[/b]
...Or at least PRETEND to listen! ;)

*checks to make sure wife isn't behind him*
 
1 - 4 of 4 Posts
About this Discussion
3 Replies
4 Participants
Mz6GreyGhost
Mazda 6 Forums
Mazda6club.com is a forum dedicated to the Mazda6 / Atenza. Come and discuss reliability, performance, modifications, and more!
Full Forum Listing
Top