Mazda 6 Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter #1
Hey y'all, just registered here, I Have a 6S wagon. I bought it in April with some known engine trouble, the previous owner broke a valve replacing the hydraulic lifters on bank one, no he didn't remove the camshafts. I found out he not only broke a valve, he bent every valve on bank one, and damaged 7 of the valve guides. I did get the top end sorted out and should be running today, provided I can acquire the torque specs for the connecting rods.
 

·
Registered
Joined
·
11 Posts
Discussion Starter #3
I did get the old AJ going again, The first go around I found out that the oil pump was weak, had to tear down and replace it. I decided to replace the oil pressure switch with an actual gauge, I did the EGR mod. The old 3.0 is pretty strong when P1447 isn't set. Goal is to replace the EGR valve, and get a set of injectors, and coils, I kinda like the old wagon.
 

·
Super Moderator
Joined
·
16,779 Posts
Welcome to the forum!

Dang, sorry to hear you bought such a mistreated 6. Good luck on your repairs and let us know how things are going :)
 

·
Registered
Joined
·
11 Posts
Discussion Starter #7
Welcome to the forum!

Dang, sorry to hear you bought such a mistreated 6. Good luck on your repairs and let us know how things are going :)
it's been a somewhat frustrating restoration. I replaced the entire EGR system due to recurring trouble codes and engine performance issues. I did The EGR mod. And then kicking myself for not replacing piston rings while the Top end was apart, has been burning through a quart of oil in 200 miles. To hopefully slow oil consumption I did a top engine cleaning(using GM cleaner and procedure) and changed to oil to a 5w40 diesel synthetic with an API SN rating, so far at 200 miles I haven't burned a quart. . I am impressed with the car now that it seems to be running right, when the heads were off I did polish up the ports a bit, very minimal porting, mostly just cleaning up sharp turns and edges, it's strength is definitly accelerating from 40 mph, real strong up to 90mph probably further but not ready to find out yet. It will do as a DD for the time being, I have an 05 Camry I'm starting a rebuild on, gonna have cylinders bored 1mm, port and polish, 1.5" lift with BFG KO2's. once that is done I'm going to do some research on the AJ, thinking of making it a stroker, but not sure, I would like to see 300hp N/A.
 

·
Rally Racer
Joined
·
1,881 Posts
it's been a somewhat frustrating restoration. I replaced the entire EGR system due to recurring trouble codes and engine performance issues. I did The EGR mod. And then kicking myself for not replacing piston rings while the Top end was apart, has been burning through a quart of oil in 200 miles. To hopefully slow oil consumption I did a top engine cleaning(using GM cleaner and procedure) and changed to oil to a 5w40 diesel synthetic with an API SN rating, so far at 200 miles I haven't burned a quart. . I am impressed with the car now that it seems to be running right, when the heads were off I did polish up the ports a bit, very minimal porting, mostly just cleaning up sharp turns and edges, it's strength is definitly accelerating from 40 mph, real strong up to 90mph probably further but not ready to find out yet. It will do as a DD for the time being, I have an 05 Camry I'm starting a rebuild on, gonna have cylinders bored 1mm, port and polish, 1.5" lift with BFG KO2's. once that is done I'm going to do some research on the AJ, thinking of making it a stroker, but not sure, I would like to see 300hp N/A.
Excellent news. This would definitely warrant a build thread.
If there was a badge to give you would get it.
 
1 - 8 of 8 Posts
Top