Mazda 6 Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
19 Posts
Discussion Starter #1
I have a 2003 Mazda6s. When shifting from 1st to 2nd gear, the car will sometimes surge - this is without
pressing the gas after shifting. In a parking lot or coming out of a garage, this can be dangerous.
This surge does not happen with our other stick shift car (Acura Integra). Dealer's
service advisor claims this is normal. Is it?
 

·
Registered
Joined
·
1,106 Posts
I suppose if you let your rpm's get to low the engine might throttle up a bit on it's own. But I dont think mine has ever done that. But I know in first gear you can pretty much let off the clutch slow, and the car will get itself just enough gas to not stall and keep rolling along.
 

·
Registered
Joined
·
19 Posts
Discussion Starter #3
There is a similar problem with 2003 Mazda 6s with auto transmissions. Here's the TSB:

TSB: 05-009/05

APPLICABLE MODEL(S)/VINS
2003 - 2005 Mazda6 2.3L vehicles with automatic transmission

DESCRIPTION
Some vehicles may exhibit 1st - 2nd shift shock under light to medium acceleration when engine temperature is cold or during warm-up. The TCM logic has been revised to correct this concern.

Customers having this concern should have their vehicle repaired using the following repair procedure.

REPAIR PROCEDURE
1. Reboot the WDS PTU to clear memory before reprogramming.
2. Using WDS B37.3 P5 or later software, reprogram the TCM to the latest calibration (refer to "Calibration Information" table) by following the "Module Reprogramming" procedure.
 

·
Registered
Joined
·
103 Posts
You may want to have this checked out with the throttle body recall. This is not the exact usual symptom, but sounds like it could be a throttle body or ecm calibration issue.
 

·
Registered
Joined
·
79 Posts
My car will sometimes do this when it is cold if I am going slow when I shift from 1st to 2nd. It revs higher when I push in the clutch than the RPMs I was running at. If the car warms up properly this is not a problem.
 

·
Registered
Joined
·
19 Posts
Discussion Starter #6
Turns out I have a torn engine mount. New part is being ordered. Dealership checked throttle body and it's ok.
 
1 - 6 of 6 Posts
Top