Mazda 6 Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
13 Posts
Discussion Starter · #1 ·
Hey guys,
So today while driving I was trying to close the sunroof (it was tilted up) and as I held the tilt down button, it closed, then proceeded to open all the way. Now, it just won't close. It sounds like the relay will click when I hit the tilt down button, no noises from anything else.

I checked this thread:
http://forum.mazda6club.com/mazdaspeed6/249958-07-speed6-gt-moonroof-issue.html

which seemed to be my issue to a T, however none of the fixes have worked thus far. I've tried holding the open/close on the slide button to wait for the "brain to reset" as was mentioned in that thread, but no dice. Also holding close or tilt down while cycling the ignition on/off doesn't seem to work.

Bad relay? Am I just giving up too easily?

Sure would like to get it to close, the nights are mighty chilly.

Thanks in advance!
 

·
Registered
Joined
·
13 Posts
Discussion Starter · #3 ·
How I fixed my broken moon roof / sun roof

Update::D

Most sunroofs have a manual close, not sure where or if so on the 6.
After much research, apparently our generation DOES NOT have a manual close. Which is unfortunate.

FIX:
So just in case anyone else has the moon roof issue, this is how I fixed it for me (I don't know a lot about cars, so hopefully this makes sense):

Open up fuse box in the cabin. Remove the 15 amp fuse labeled "Room" (near the bottom). I then checked to make sure the relay/motor wasn't getting any power by clicking all of the moonroof control buttons (probably not necessary, but in dealing with household electronics with 'brains' this is a good way to make sure power is completely cycled) I let it sit for about a minute, plugged the fuse back in, and tried the moonroof controls again. The first time I clicked nothing happened, but when I held down close, sure enough, it closed.

Now, while I did this, I had the car turned onto the accessory position, so everything was on in the car. I'm not sure why I did this, I probably just forgot to turn it off, but just in case that has something to do with the fix, I though I'd include that.

What is really surprising to me is that from most of the searching I did, the clicking sound coming from the relay was a "sure bet" that the relay was bad, apparently not.

Hope this can help someone else in the same situation.
 

·
Registered
Joined
·
1 Posts
Mine turned out to be the 10 amp "A/C" fuse that was blown. Replaced it with the spare, started the car, pressed slide and the moon roof closed right away. My advice would be to just check all of the fuses inside the cabin panel.
 

·
Registered
Joined
·
558 Posts
I have had this happen a few times and it is quite the pisser...

Most times just waiting it out or continuing to hit the button did the trick... One time it did pop the fuse though.
 

·
Registered
Joined
·
1 Posts
Hey guys,
So today while driving I was trying to close the sunroof (it was tilted up) and as I held the tilt down button, it closed, then proceeded to open all the way. Now, it just won't close. It sounds like the relay will click when I hit the tilt down button, no noises from anything else.

I checked this thread:
07 Speed6 GT Moonroof Issue.

which seemed to be my issue to a T, however none of the fixes have worked thus far. I've tried holding the open/close on the slide button to wait for the "brain to reset" as was mentioned in that thread, but no dice. Also holding close or tilt down while cycling the ignition on/off doesn't seem to work.

Bad relay? Am I just giving up too easily?

Sure would like to get it to close, the nights are mighty chilly.

Thanks in advance!
For future reference for anyone with this problem on MY 2006 mazda 6 touring edition the motor just got stuck remove light/switch panel on roof tap the motor a couple times and try the buttons to slide it back if this does not work either you need a new motor or you didnt tap hard enough!
 

·
Registered
Joined
·
3,811 Posts
For future reference for anyone with this problem on MY 2006 mazda 6 touring edition the motor just got stuck remove light/switch panel on roof tap the motor a couple times and try the buttons to slide it back if this does not work either you need a new motor or you didnt tap hard enough!
Its a known issue, pull the neg bat cable for about 20 mins to reset the BCM.
 
1 - 7 of 7 Posts
Top