Mazda 6 Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
Experiencing this intermittent problem that I can't figure out... While driving the RPM will suddenly spike causing the car to jerk... The "D" gear light also flashes when this happens.... The tricky part is that it also flashes randomly throughout driving and it's not accompanied by the rpm spike so it can be a totally separate issue. Took it to Mazda and they did a diagnosis... No engine codes but claimed my transmission pressure switch needed to be changed. I changed that on my own with a transmission flush and still no luck.... Seeing possible causes ranging from Throttle Position Sensor, to transmission needing to be rebuilt, to PCV valve, to shift linkage...... I'm at a loss... Any thoughts? Captured some video of issue. Cheers


https://youtu.be/BobSnEnXUvg
 

·
Registered
Joined
·
484 Posts
Does it happen when you drive it in manual mode?
If it doesn't, it could be your linkage... now, does your 6 have an actual linkage or an electronic shifter? If it is electronic, it could be a bad contact.
 

·
Registered
Joined
·
6 Posts
Discussion Starter #3
To be honest i never drive in manual mode but i'll give that a try this week...see if it still occurs..also i have no clue how to tell if i have an electronic shifter or linkage...thanks
 

·
Rally Racer
Joined
·
2,191 Posts
To be honest i never drive in manual mode but i'll give that a try this week...see if it still occurs..also i have no clue how to tell if i have an electronic shifter or linkage...thanks
If you look at the top of the transmission you will see a thick cable (that does not make any sharp bends) coming from the firewall and attaching to the transmission if you have a mechanical linkage.

Below is a manual transmission cable but it basically the same.

 

·
Registered
Joined
·
6 Posts
Discussion Starter #5
So tonight driving home in manual mode the problem popped up again. A small "AT" light started flashing and the rpm spiked as if it were in the wrong gear..... There was a big jerk accompanied with a loud bang or backfire type of sound as the car tried to kick into the right gear.......I feel like maybe something is engaging and disengaging all the time.... But the actual jerking of the car doesn't happen all the time.... The gear light does Flash at random times... Both with and without the jerking.... Maybe it's a bad contact like you suggested and when the contact is really bad then the jerking/gear change problem occurs??

Is there a way to know if I have an electric shifter or manual linkage just by knowing my car make and model and year? Don't really have a place to open it up right now. It's a 2010 Mazda 6 GS Automatic.

Thanks all for your help. I've been trying to isolate if this happens at a certain time or situation to troubleshoot but it truly seems random..
 

·
Registered
Joined
·
6 Posts
Discussion Starter #6
Watching some YouTube videos which suggests these symptoms could possibly point to the TCM needing replacement... Anyone have a diagram of where the TCM is located on this car? Might be worth trying to replace that if the part isn't too expensive?
 
1 - 6 of 6 Posts
Top