Mazda 6 Forums banner

1 - 9 of 9 Posts

·
Registered
Joined
·
285 Posts
Discussion Starter #1
hi everyone
does anyone have problem with stalling issues with their 2003-2005's?
and I mean automatic transmissions, yes autos, isn't that weird?
what could be some of the possibilities?
I was told that my throttle body was replaced last september..
I got my car back in 2004
first stall occured 2 months after I bought my car
and it has happened 4 times now (occasionally)
I have brought it back to the dealers 3 times already and they said they didn't find anything on the computer nor any updates
 

·
Registered
Joined
·
111 Posts
hi everyone
does anyone have problem with stalling issues with their 2003-2005's?
and I mean automatic transmissions, yes autos, isn't that weird?[/b]
Yes. I had my '06 Wagon with 3.0L and 6-speed Automatic for about 2-months when this happened to me too, so I don't think this issue is limited to '03-'05 models.

I was in stop and go traffic on the highway, and immediately after taking my foot off the gas to coast for a second in the stop and go traffic, then engine quit. At first I thought the car was dead, but I coasted to the shoulder, but the car in neutral and the engine started right back up. It scared me a little, but only happened once more over the 29000 miles I had it. I had caught the engine almost stalling several times, but it usually recovered. I did notice the problem seemed to be worse when the A/C was OFF. The computer's bump up the idle speed when the A/C is on.
 

·
Registered
Joined
·
1 Posts
I have a 2007 Mazda 6 V6 Automatic for about 7 months now and have had it stall twice. First time i was coasting to the stoplight and car suddenly stalled, didn't shake or anything the engine just stopped. I was going at a slight incline so i had to roll backwards to the side of the curb and started it right back up. Car ran fine since then but just yesterday it did the same thing as i was about to pull out from the driveway of a parking lot. I started it right back up and seem fine afterward, but its just really weird. The car was brand spanking new when i bought it so this is a bit disturbing. I'm going to take it in to get it checked out, but just wanted to find if anyone else is having this problem in their 07. Just thought i put this out there, if anyone has any recent issues like this too...
..what could it be "throttle body," fuel pump, battery?

Thanks,
 

·
Registered
Joined
·
185 Posts
my 06 did it for the first time about a week ago. i was coming up to a stop sign and as i went to turn onto the intersecting street the steering got heavy and no go at all. So i popped it into neutral and restarted, put it in D and took off fine. Thank god there was no traffic coming down the street that i turned onto or i woulda been t-boned. It was only about 3 blocks from my house so its possible the car wasnt warm enough and i had the AC blasting on 3. Since then i've let the car warm up a few minutes-3-4.(how long to warm up when its 95 degrees out ALL the time. damn u so fl). But if it happens again i might have to waste a trip to the dealer...
 

·
Registered
Joined
·
8 Posts
I started to experience hesitation and stalling recently mostly when the tank was around 1/8 and the car was on an incline (going up a garage ramp or coming down an off ramp). I took it in and they replaced my fuel pump. Seems to be working great now, and the funny thing is, my mileage, which has been abysmal since the day I got this car, has suddenly improved substantially.

QUOTE (Starkos @ Jul 12 2008, 09:34 AM) index.php?act=findpost&pid=1388628
I have a 2007 Mazda 6 V6 Automatic for about 7 months now and have had it stall twice. First time i was coasting to the stoplight and car suddenly stalled, didn't shake or anything the engine just stopped. I was going at a slight incline so i had to roll backwards to the side of the curb and started it right back up. Car ran fine since then but just yesterday it did the same thing as i was about to pull out from the driveway of a parking lot. I started it right back up and seem fine afterward, but its just really weird. The car was brand spanking new when i bought it so this is a bit disturbing. I'm going to take it in to get it checked out, but just wanted to find if anyone else is having this problem in their 07. Just thought i put this out there, if anyone has any recent issues like this too...
..what could it be "throttle body," fuel pump, battery?

Thanks,[/b]
 

·
Registered
Joined
·
275 Posts
I know this is an old thread but today my car did this exact thing but happened four different times in the same drive. My gas tank was full and I had the a/c on. I am quite worried because it happened to me five times today but only twice before that. It's happened in cold and hot weather and on inclines and off them. It's wierd because the rpm meter would dip below 700 and I would have to give it a little throttle or else it would die. I am mainly reviving this thread because there is only one answer on here and that is to replace the fuel pump. If anyone else has any answers or the same problem please post. I need an answer asap. Oh yeah, I have an 05 6i.

My gas mileage has also been sub par lately, right above 20, it is all city but it should get more than that. I have gotten more than that with the same driving style.
 

·
Registered
Joined
·
1,078 Posts
are there any TSB's(technical service bulletine) for those systems for your model? you might have to do your homework.
 
D

·
Guest
Joined
·
0 Posts
I know this post is really ancient, but did you ever find the problem
 
1 - 9 of 9 Posts
Top