Mazda 6 Forums banner

1 - 9 of 9 Posts

·
Registered
Joined
·
1,212 Posts
Discussion Starter #1
trying to get it in before the winter I tried installing my eibach pro kit today. on the front I got stuck trying to remove the nut from the sway bar. damn thing kept spinning in both locations. Anyone have any suggestions?
 

·
Registered
Joined
·
3,161 Posts
If you look closely, there is a hole in the bolt. Use a allen key to hold the bolt down while using a wrench to loosen it.
 

·
Registered
Joined
·
1,212 Posts
Discussion Starter #3
got the fronts on, never could get that bolt. just need to find out where the noise is coming from the pass. side. I didn't get the top lined up perfect, so I'll probably need to fix that tomorrow or friday. rear's tomorrow!
 

·
Registered
Joined
·
1,550 Posts
dream weave im getting a prokit. How did you do the whole compression thing and have u ever done suspension before.?
How long did it take?
 

·
Registered
Joined
·
1,212 Posts
Discussion Starter #5
dream weave im getting a prokit. How did you do the whole compression thing and have u ever done suspension before.?
How long did it take?
[/b]

I rented the spring compressor from autozone. I spent an hour this morning trying to get that last bolt off, and went back at it after lunch. it took me about 3 hours for the fronts, I had to reposition the spring compressors so I could fit the top back on. not until the 3rd time trying to ratchet the compressors did I think to use my impact wrench. cut the second one in the front down to about 45 minutes.

first time spring install for me
 

·
Registered
Joined
·
2,828 Posts
You'll love doing the rear springs lol. I just did mine with the eibach Sportlines couple months ago..

If you had problems with that bolt. You'r going to HATE whats to come.

Getting everything off for the rear springs is simple. Getting it lined up an back on. Not exactly so simple lol.
It was my first spring install. so maybe that's why. But i was swearing and cussing pretty damn loud trying to put the back, back together.


I screwd up on the fronts and forgot to put the little rubber piece from the stock springs on to the top o fthese springs. So whenever I hit a bump, I get this clanky sound from the front. Been procrastinating on going back in and putting it on.
 

·
Registered
Joined
·
160 Posts
how did you get the bolt on the top loss. I end up having to bring the shock/spring asemably to pep boys to have them us an impack gun to get it loss.
 

·
Registered
Joined
·
2,828 Posts
how did you get the bolt on the top loss. I end up having to bring the shock/spring asemably to pep boys to have them us an impack gun to get it loss.
[/b]
I had air tools when I did mine lol. I cheated for my first time
 

·
Registered
Joined
·
3,161 Posts
how did you get the bolt on the top loss. I end up having to bring the shock/spring asemably to pep boys to have them us an impack gun to get it loss.
[/b]
What bolt are you guys referring to?? The one that holds the shock to the upper strut mount? For that one, you need to clamp down the top of the shock otherwise if you try to take the bolt off, it'll just turn and turn and turn. It's not that difficult.
 
1 - 9 of 9 Posts
Top