Mazda 6 Forums banner

1 - 13 of 13 Posts

·
Registered
Joined
·
32 Posts
Discussion Starter #1
I NEED HELP AGAIN, MY SPEEDOMETER IS NOT WORKING AND IT IS NOT READING THE MILES, DOES ANY BODY HAVE ANY IDEAS OF WHAT THE PROBLEM MIGHT BE. PLEASE HELP.
 

·
Registered
Joined
·
32 Posts
Discussion Starter #3
my dome lights do work i have checked all my fuses and they are all fine also. everything on the dash works fine with the
exception that my check engine light is on and my tcs off light wont go off and there is one with a litthe car with curvy lines behind it on also.
 

·
Registered
Joined
·
2 Posts
I NEED HELP AGAIN, MY SPEEDOMETER IS NOT WORKING AND IT IS NOT READING THE MILES, DOES ANY BODY HAVE ANY IDEAS OF WHAT THE PROBLEM MIGHT BE. PLEASE HELP.[/b]

Did you ever find out wye your Speedo wasn't working
 

·
Registered
Joined
·
137 Posts
Do you have any lights on? Is the car throwin any codes? It could be either your TCU (Trans control Unit) or VSS (vehicle speed sensor). I had a Hyundai that did this quite often, fault in the technology with their "fly by wire" throttle system.
 

·
Registered
Joined
·
3 Posts
When I removed my car's battery (in 2 occasions of positive first and also negative first), odometer, fuel meter, temp. meter, trip meter and all other instrument indications got reset. Even after connecting back the battery, these readings are not coming. Some of the readings (fuel, temperature, speedometer and tachometer)are coming some times started and were running throughout that running time of car. Once car is stopped and if immediately started, again coming and started after some times, not coming. Means as a whole during this one week 3 or 4 times it appeared. My car is Mazda 6, 2007 model.
 

·
Registered
Joined
·
160 Posts
ever get this solved? i have tcs light on and no speedo also, getting ready for a 1200mile trip and really need to fix it this weeek!
 

·
Registered
Joined
·
1 Posts
I have the same issue. The speedometer and odometer not working, TCS light is on. Dome lights work and the dash lights work.
All fuses are good. 2007 Mazda 6 AT
 

·
Registered
Joined
·
2 Posts
Hi mcjas63

Did you figure out the problem you head. I have same problem as you posted.

Much appropriate if anybody can help out.
 

·
Registered
Joined
·
1 Posts
Ive got this problem with my mazda 6 2004, my speedometer not working. But there were time that it works when tcs light is on. What could be the cause of this?
 

·
Registered
Joined
·
584 Posts
Ive got this problem with my mazda 6 2004, my speedometer not working. But there were time that it works when tcs light is on. What could be the cause of this?
You might have a faulty speed sensor. I don't where it is on Mazda but on our CR-V 98, it is attached to the transmission. It is a spur gear and each revolution has an equivalent speed.

Another possibility is that the instrument cluster is faulty.
 
1 - 13 of 13 Posts
About this Discussion
12 Replies
12 Participants
Archerfish
Mazda 6 Forums
Mazda6club.com is a forum dedicated to the Mazda6 / Atenza. Come and discuss reliability, performance, modifications, and more!
Full Forum Listing
Top