Mazda 6 Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Alright, I am looking into buying a mazdaspeed 6. It's a 2007 model and I just simply can not figure out why this thing wont start. And the sad part is, the dealer wrote "RUNS AND DRIVES" on the windshield.lol. Anyways, the car had a terrible oil leak which I was able to figure out, but that does me no good when I can get it to start. It will start though if they pull it around and pop the clutch. HAHA. The car ran for a little bit after they did that, but it was missing like crazy. I pulled the plugs and check them all and did compression test. Everything checks out. But, I noticed all plugs were dry, absolutely no fuel. Basically, I'm wondering if these damn cars have an inertia fuel cut off switch or something like that, because it has front end damage, but my brother said he heard the fuel pump prime up when i turned the key on. I didnt think of that until I got back home from the salvage dealer and it was too late to go back and check. Ill check tomorrow. And I'm posting this to see if anyone else has had the same problem, and what they did to fix it. It also flashes the CEL 8 times when key is turned on. Now, one last thing, when we were taking all of this apart I noticed there was some oil inside the intercooler piping and intercooler. It just seems to me that the damn car isnt suppose to breathe oil. Anyways i know I should probably leave this deal alone but he is cuttin me a good price, but if I cant get it running good then obviously I dont want it. PLEASE SOMEBODY HELP ME SOON, I WANT THIS DAMN CAR.
 

·
Registered
Joined
·
1,271 Posts
check the high pressure fuel pump.. its gold colored and attached on the back of the valve cover, drivers side.
 

·
Registered
Joined
·
400 Posts
check fuses
 

·
Registered
Joined
·
295 Posts
everything cant be solved by asking others online, you havent provided enough information, does everything turn on, does it crank but not start etc
 
1 - 4 of 4 Posts
Top