Mazda 6 Forums banner

1 - 20 of 24 Posts

·
Registered
Joined
·
169 Posts
Discussion Starter #1
My car wont start and the security indicator light keeps flashing, it is the one that depicts the car with a key in the middle. Has this happened to anyone?
 

·
Registered
Joined
·
443 Posts
Does this flashing happen when the key is in the on or off position? It is normal in the off position. Please describe more of the situation. Do the dash lights dim? Does the starter motor rotate? etc.
 

·
Registered
Joined
·
169 Posts
Discussion Starter #3
QUOTE (chilimax21 @ Nov 13 2008, 02:04 PM) index.php?act=findpost&pid=1475978
Does this flashing happen when the key is in the on or off position? It is normal in the off position. Please describe more of the situation. Do the dash lights dim? Does the starter motor rotate? etc.[/b]
When I try to turn the car on it only makes clicking noises. Lemme check if the lights dim.
 

·
Registered
Joined
·
1,324 Posts
QUOTE (jumpman23j @ Nov 13 2008, 04:12 PM) index.php?act=findpost&pid=1475985
When I try to turn the car on it only makes clicking noises. Lemme check if the lights dim.[/b]

The clicking sound could be due to a bad battery. Are your dash gauges jumping all over the place when you try to crank the engine?

Try jump starting your car and see what happens, but I'm betting you need a new battery.
 

·
Registered
Joined
·
810 Posts
try a jump. if that doesn't work, get a new battery.
 

·
Registered
Joined
·
1 Posts
QUOTE (its rayden @ Nov 15 2008, 03:03 PM) index.php?act=findpost&pid=1476661
try a jump. if that doesn't work, get a new battery.[/b]

Hi... the same thing happend to my car today..someone from mazda came to my house to check... it's not the battery.. jump start won't help either.. apparently, it has something to do with the key.. the car doesnt recognize the key or something.. it's also in our manual.. they need me to try using the spare key.. but my bf has it.. hehe.. so im gona try later on tonight.. my car is only a year old.. im not sure tho why it's happening... ;/
 

·
Registered
Joined
·
9 Posts
QUOTE (emz @ Dec 17 2008, 02:43 AM) index.php?act=findpost&pid=1491323
Hi... the same thing happend to my car today..someone from mazda came to my house to check... it's not the battery.. jump start won't help either.. apparently, it has something to do with the key.. the car doesnt recognize the key or something.. it's also in our manual.. they need me to try using the spare key.. but my bf has it.. hehe.. so im gona try later on tonight.. my car is only a year old.. im not sure tho why it's happening... ;/[/b]

any update on this? I got something similar going on and would love to hear the fix
 

·
Registered
Joined
·
14 Posts
QUOTE (emz @ Dec 17 2008, 09:43 AM) index.php?act=findpost&pid=1491323
Hi... the same thing happend to my car today..someone from mazda came to my house to check... it's not the battery.. jump start won't help either.. apparently, it has something to do with the key.. the car doesnt recognize the key or something.. it's also in our manual.. they need me to try using the spare key.. but my bf has it.. hehe.. so im gona try later on tonight.. my car is only a year old.. im not sure tho why it's happening... ;/[/b]

What was the resolution?

Today, I went out to the car, turned the key and it would not start. All of the dash lights are flickering on and off but the car is not turning over.
 

·
Registered
Joined
·
9 Posts
QUOTE (tagbert @ Aug 8 2009, 11:24 PM) index.php?act=findpost&pid=1590195
What was the resolution?

Today, I went out to the car, turned the key and it would not start. All of the dash lights are flickering on and off but the car is not turning over.[/b]
my issue turned out to be some dillhole before I bought the car left a battery fill cap loose and I have/had massive corrosion on the main power wire from the battery all the way to the starter... everything looked normal, but it wouldn't turn over...

dunno if that will help your situation or not...
 

·
Registered
Joined
·
1 Posts
QUOTE (nodakbassmaster @ Aug 9 2009, 12:31 AM) index.php?act=findpost&pid=1590198
my issue turned out to be some dillhole before I bought the car left a battery fill cap loose and I have/had massive corrosion on the main power wire from the battery all the way to the starter... everything looked normal, but it wouldn't turn over...

dunno if that will help your situation or not...[/b]
Hey, what happen with your situation. I seem to have the same problem with the dash flickering all over the place when I try to turn on the car. I tried to jump start the car today but it would not work. However, I did notice a large build up of corrosion on my battery, did you have to get the battery replaced?
 

·
Registered
Joined
·
3 Posts
Glad I found pwrpff's note. Battery acted completely dead, jumpstart no help, engine gauges jumping madly. I changed to backup key, while jumpstarting and car powered up as expected. I'll attempt to re-register the first key shortly.
 

·
Registered
Joined
·
44 Posts
I cant believe there's so many people on here with this same issue with no "true" answer. Does not a single person have a follow up on this issue? lol

Thats what the point of these forums are. Person A has a problem and asks for help, nobody has an answer (or the correct one at least). Person B comes along, same issue, still no answer. However, at least 6 months have past since person A asked the original question. Now we have person C join the fun, same issue, still no answer. Etc, etc.

I mean come on guys, really. Post up what the fix was to help those that come along after with the same issues. Usually, thats what one of the good things about forums are. But if nobody posts up what the fix was, then its a never ending useless thread with 10 new members (1 post each) asking the same question.

Anycase, I now have another issue with my gf's 6 and came here to look for an answer. Thankfully this isn't my car, cause after all these issues she's having with it, if it was mine it would be going off a cliff.

I'll make sure when I fix this junk that I post up what the issue is that caused this, and how it was fixed.
 

·
Registered
Joined
·
44 Posts
Well it was stupid of me to think anything other than dead battery. So for anyone else experiencing this problem, because it seems like lots of people have had this issue, check your battery before you do anything else.

I checked it with the key off and it read 12.40ish, and with the key to on it was 6.70ish. I brought the battery to autozone and had them load test it and the kid said it was no good. New battery with a 2 year warranty for $95 out the door. Put the new battery in and all is well.

It just didnt seem right to me that we were just out and 15 minutes later the battery was dead. So I freaked out and went online to see if others had this issue and all I did was get myself more confused with key calibration, corrosion on the terminals (it was clean as could be), bad relays, etc etc. So I guess if your battery is gonna go, its gonna go whenever it feels like it. I'm just happy this happened at the house and not in the middle of nowhere. :)
 

·
Registered
Joined
·
3 Posts
hi sorry to bring this old thread back to life but i need help. i researched and found nothing like my problem similar but not enough... ok so i bought my 04 mazda 6 v6 last night.. the remote control doesnt work.. so acordding to what i been reading on the forums thats normal since the previous ower replaced the battery last weekend. the car came with just one remote and the key (spade key). so i been using the key to open the car. however today after work (not driving the car yet) i tried to unlock the car as usual using the spade key but it didnt work! i put the key inside the driver door but it wont turn neither left or right! i noticed the security light(a red light with the shape of a key) is flashing inside the car! same thing with the trunk!!! so now i cant unlock the car!!! please i need help asap!
 

·
Registered
Joined
·
74 Posts
Wrong key for the door. Every car does not use a chip to unlock the doors manualy with a key. Unless its like way high end. Your barrels In your doors must be different than your main key. Your battery in your keyfob might be dead and or got unsync with the car. You'll find a manual for how to resync in the forums
You'll need to unlock the car with a Jimmy or a hanger and take the battery out and test it
 

·
Registered
Joined
·
1 Posts
Here is the problem I am facing: Car Does not start sometimes... So, the problem is intermittent.

This is what I have tried so far, but the problem still persists:
1) Changed Battery (Lights, indicator, etc all work perfectly), so battery issue is ruked out.
2) Changed the relay. But this did not solve the problem.
3) When the car did not start, got a local mechanic to check the electrical parts... He confirmed that electrical stuff has no issues
4) Have stopped using remote and use the key instead to lock/unlock doors. But this does not work either.

This is what I have observed when the car does not start:
1) All the lights (battery, engine, hand-break, battery) appear properly when the car is ON.
2) I also observe that the key symbol stays on. After a minute, the key symbol starts to blink. I tried to use the spare key, but that does not start still...

What works:
=========
The local mechanic removed the battery wires and fitted them again. The car started. This happened on 2 occasions.

I have a doubt that it could be a problem with the key or the computer.... Any ideas please ? What should I do ?
 

·
Registered
Joined
·
1 Posts
I have a 2008 mazda 6, yesterday my car started up just fine, I turned it off for about 15mins got back in the car to leave and it wouldn't start, Ive had three different people try to jump me and nothing happens, I've tried buying a new battery still nothing. My dashboard lights wont come on, neither will my radio but headlights will turn on when I put the key in the ignition and turn it to the on position the security light flashes with the little car symbol im not sure whats going on I've heard it could be my starter or the security indicator system, I've had the car for almost 2 years now and never had this problem.
 

·
Registered
Joined
·
1 Posts
Similar Problem

I have a 2006 Mazda 6. A few months back, I returned to my car and found the battery was dead. I jumped it, drove a few minutes and them ate lunch. After eating, the car would not start again. I had to jump it again, and drove it for 30 minutes, hoping the alternator would charge the battery. I went to work. After a few hours, I returned to the car and it started on its own. I took it to Autozone and tested the battery. The battery was dying. Replaced the battery, and had no problems. However, I need to mention that when I jumped the car the first time, the security indicator (red car with key in it) came on and did not want to let me start the vehicle. With my foot on the brake, I rapidly fidgeted the key in the ignition and the car started. Now, a few months later, on occasion, I will insert my key to start the car, and when I turn the key, the car acts like the action of turning the key kills the battery. Everything goes dead, the gauges go berserk, and the security indicator flashes. I have to pop the hood, disconnect and reconnect the battery terminals and then put my foot on the brake while turning the key to get the car to start. I'm not positive, but am hopeful that having the key re-registered to the vehicle helps. On a side note, my FOB has a short, and so if I put a battery in it, the FOB will go through the battery in about 4 days time. So I never use the FOB, always use the key for opening doors, trunk, etc.

If anyone has had a similar issue and has found a solution, feel free to share.
 

·
Registered
Joined
·
1 Posts
I having the same issues on my 2007 Mazda 6. Brand new battery, brand new alternator. Car will start with a jump, when you shut it off the red light with a key on the dash flashes. I think this indicator light is draining my battery because if you wait longer than 15 min. or so there's not enough juice to start it. I am experimenting with a new key FOB battery now. The manual calls the red light the "security indicator", flashing red has something to do with the immobilizer. I will update after i throw a new battery in the FOB and re-register the FOB to the car. I hope this solves the problem. getting annoying that nobody has a solid fix for this yet.
 
1 - 20 of 24 Posts
Top