Mazda 6 Forums banner

1 - 19 of 19 Posts

·
Registered
Joined
·
12 Posts
Discussion Starter #1
I have an 07 mazda 6 which recently started rough idling and stalling. In certain gears (automatic) the car is so bad it bounces. Rpms are below 1000, constant mis when driving. We have replaced a fuel injector, the o rings on the injectors, the valve cover gaskets, intake gaskets, cleaned throttle body, replaced pcv hose, spark plugs, ignition coils..... anyone can help??? Want to fix myself before taking it to mechanic. I can get a video of what its doing if needed.
 

·
Super Moderator
Joined
·
17,747 Posts
Welcome to the forum!

Some more simple things to check:

Cleaned/replaced your MAF?
Checked for vac leaks?
Any cracks in the accordion intake tube?
 

·
Registered
Joined
·
12 Posts
Discussion Starter #8 (Edited)
Thank you, Byakuya! Those were my next options, from everything i have been reading i have a list of sensors to check/replace. I dont have a way to check for vac leaks.I had also read about fuel filter and fuel pump.. other than that im at a loss.
 

·
Registered
Joined
·
12 Posts
Discussion Starter #9
We got 4 different codes off the car today, PO300 PO302 PO2096 and PO171. we wrote them down and took the car to our mechanic.. will update when he figures out exactly what is going on .
 

·
Registered
Joined
·
12 Posts
Discussion Starter #12
* update : car has a bad vac leak around intake manifold, thinking its where pcv is. Mechanic is going to fix that and see what happens on Monday.
 

·
Registered
2005 Mazda 6s
Joined
·
9 Posts
* update : car has a bad vac leak around intake manifold, thinking its where pcv is. Mechanic is going to fix that and see what happens on Monday.
I have a very similar problem occurring right now. when you get the car back, could you let me know exactly what the mechanic did please?!
 

·
Registered
Joined
·
12 Posts
Discussion Starter #15
@Zachb1030 only thing we know right now is my pcv valve is cracked and the hose had a hole in it. Once he gets the car back together we will know if thats truly the problem.
 

·
Super Moderator
Joined
·
17,747 Posts
@Zachb1030 only thing we know right now is my pcv valve is cracked and the hose had a hole in it. Once he gets the car back together we will know if thats truly the problem.
That's definitely not going to help a rough idle. Make sure the replacement hose is the reinforced one that looks like this, with the rectangle rubber around the long hose part:
242167
 

·
Super Moderator
Joined
·
17,747 Posts
Ok folks, got the car back today. The pcv valve was busted and hose had a good size hole in it. That fixed my issues for now!
Thanks for reporting back, glad it fixed your issue. I'm curious though, you said in the OP that you had replaced the PCV hose, did that one fail again already or was that a while ago?
 

·
Registered
2005 Mazda 6s
Joined
·
9 Posts
Ok folks, got the car back today. The pcv valve was busted and hose had a good size hole in it. That fixed my issues for now!
Thanks for the reply, sadly mine has been replaced already and not an issue.. Thanks for responding though!
 
1 - 19 of 19 Posts
Top