Mazda 6 Forums banner
1 - 4 of 4 Posts

·
Registered
Joined
·
12 Posts
Discussion Starter · #1 ·
Hi guys,

I posted here earlier about an issue I had with my 2004 Mazda 6 2.3l auto, where the instrument cluster was lighting up with multiple errors, speedo not working etc. After spending $132 to diagnose the problem by Mazda, it turned out to be the ABS module. So, I went out and bought one for $300, had it professionally installed (another $170) and while everything is back to normal on the dash, the car seems to be misfiring and running very rough when I accelerate even slightly. If I disconnect the ABS module however, the motor runs perfectly fine. My question is whether the module needs to be somehow reset to match my car? Why is something so unnecessary, causing so much drama? Please help? I've been off the road for a month now :(
 

·
Registered
Joined
·
12 Posts
Discussion Starter · #2 ·
OK, since I never got an answer and spent around $1,000 between mechanics and tow trucks, there is finally a solution I thought I'll write up in-case anybody else comes across this problem in the future... It turned out that the ABS module that I replaced had the traction control option (TCS) and because my car never had TCS, the computer was getting the wrong messages and was cutting out the fuel to the engine thinking that my wheels are spinning but in fact they are not. Will be replacing the module again with the proper part number that matches my car. So, if anybody else has this problem in the future, make sure you get the right ABS module for your car and match those part numbers or your car will not be going anywhere...
 

·
Registered
Joined
·
1 Posts
My 04 mazda is losing power going up hills. I changed my tcm an in still having the same problem. My car will jerk then in unable to accelerate i have to turn the car off restart it then try again. Can someone plz help me? What can this be?
 

·
Registered
Joined
·
4,262 Posts
My 04 mazda is losing power going up hills. I changed my tcm an in still having the same problem. My car will jerk then in unable to accelerate i have to turn the car off restart it then try again. Can someone plz help me? What can this be?
Its best to start your own thread than reply to one thats years old with no solution. Give us a shit ton of details not just "my car doesnt run" (example).
 
1 - 4 of 4 Posts
Top