Mazda 6 Forums banner

1 - 19 of 19 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hi,

I've got a UK Mazda 6 2009 2.2 Diesel Sport with keyless entry and smart key.

Yesterday I tried to start it but when I depressed the clutch (the clutch is used instead of brake on the manual gearbox) the Start Button / Advanced Key light initially turned green, but then both changed to red as soon as I tried to start it and the carhttp://forum.mazda6club.com/# would not start. After that both the start button and the advanced key light would always appear red when trying to start the car.
I tried the spare key, tried replacing batteries in key fobs, tried the backup key/s in the ignition, etc, all to no avail. I could still lock / unlock without any issue.
Had the same problem last year. Car has been taken to the dealer, and what? All they done is: checked all connections and clear fault codes and after all they start the car. Useless !!!
AGAIN a month ago on my weeding day :( the same problem. Two fault codes related to : key fob and clutch switch.
Guy clear the codes and start the car without a problem and he told me the steering lock must be changed.
No probs until yesterday.
Again
Car has been diagnose by different guy.
This time different code and only one: (B102692 electronic ignition lock Malfunction)
And been told have to change electronic ignition lock.
Phone a dealer and their system is showing nothing under "electronic ignition lock" all they can find on their system is (steering lock) ???
Are those two the same parts????
Will replacing this part resolve my problem???
Two times different codes???What to do???
Please guys HELP!!!!! I'm confused :(:(:(
 

·
Registered
Joined
·
766 Posts
Has the engine battery been replaced? When batteries begin to weaken, there may not be obvious symptoms like dimmed light or long engine cranking but electronics sometimes feel the effects. If the battery is older, it's probably not a bad idea to replace it anyway. Or it is newer have it checked out. If its ok, try unhooking the battery for a few minutes and see if that doesn't reset the problem.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
HI Trippp.
Battery has been replaced two months ago and has been checked by the guy which fix my car last time and is OK.
I've try disconnect battery few times but no luck.
Is just impossible to clear those codes like that.
There is a problem to connect to the ecu to clear the codes because most diagnostic computers need ignition on for connection when red light appear on the button and dash I can't turn ignition on.
Thanks.
 

·
Registered
Joined
·
1 Posts
Red Button

Darius29uk; I have exactly the same problem! Did you ever cure the fault as mines seems to be getting more and more frequent? If you traded the car it wasn't Black one was it? :|
 

·
Registered
Joined
·
4 Posts
Hey, same here! The key light in the dash would not turn from red to green...

I have tried:
Both keys to start, removed battery negative terminal cable, gave jumpstart power from another vehicle, checked all the fuses, tried to read the OBD2 (but not possible because cannot get ignition on).

Anyone resolved this problem?
 

·
Registered
Joined
·
4 Posts
Yes, i have tried the physical key, but it made no difference. Also the batteries in the remotes are less than 1 month old.

The car is towed to a Mazda repair shop. Called them yesterday and they dont have a clue whats going on with the car... nice :grin2:
 

·
Registered
Joined
·
4 Posts
Got the car back.

They had to change the steering lock and the keyless entry module. Parts and labor where 2278 pounds (equals 2934 US dollars and about 2500 euros).

My Mazda6 is a piece of ****.
 

·
Registered
Joined
·
5 Posts
Yes TalonTsi90
But the ansewer just i bring to Mazda service. But the mechanic solution this problem 3 week earlier and until at yesterday wasn't problem. But at now again, and I looking the solution but I can't find it anywhere.
 

·
Registered
Joined
·
2 Posts
Yes TalonTsi90
But the ansewer just i bring to Mazda service. But the mechanic solution this problem 3 week earlier and until at yesterday wasn't problem. But at now again, and I looking the solution but I can't find it anywhere.
So I currently have this problem. Can't even get the car into ON mode to use a diag tool on it. Dealer finally got it to throw a code. The immobilizer and steering rack must be replaced. $3,000 after parts and labor. Bought a used rack and replacing this weekend and will have towed back to the dealer to reprogram.
 

·
Registered
Joined
·
5 Posts
The mechanic told me must be changed the steering wheel lock, but I not really can find used in Hungary.

I work for a car parts company. I asked for a factory quote based on the chassis number for the steering lock. But in the ansewer was ignition switch. So if I think good the ignition switch included the steering lock ? Beacuse the original ignition switch was 217.000 HUF (about $723). I think the steering lock little cheaper. And he thinked for the emulator ( Seat sensor ) my warming seat not working As well but this poblem have since summer so I not think this a problem.
 

·
Registered
Joined
·
2 Posts
I have the exact same symptoms as you do. Have just replaced the keyless module, but seems like it didn't fix it. Did you guys have any success?
 

·
Registered
Joined
·
5 Posts
On this weekend the mechanic gonna exchange the steering lock and teaching to key. I hope will good, but if this will not solution. I have absolute no idea what can i do.
 

·
Registered
Joined
·
2 Posts
(y) Best of luck! And keep us posted! I'm taking my car back to the dealer today to see if they can read any new codes.
 

·
Registered
Joined
·
5 Posts
Nothing yet. I couldn't talk with mechanic today. He has got lot of job. I gonna try again tomorrow. When will anything news I gonna write here.
 
1 - 19 of 19 Posts
Top