Mazda 6 Forums banner

21 - 40 of 48 Posts

·
Registered
Joined
·
1,477 Posts
Same problem here....just got it fixed from the dealership yesterday and everything is working perfectly. I sure did miss the auto locking feature and pressing the door handle button to lock or unlock. Viva la Mazda!! :love:[/b]
My Red key light has been on and off for a month. My car has been at the dealer 4-5 times just for the advanced keyless entry system. In fact, the day after the dealer "fixed" it the last time, the red light came on.

It's frustrating. I understand this is a "convenienece" feature. But I used to keep the key in my wallet and forget about it. Now I am constantly forgetting it in my pants pocket from the previous day or having to find the card in my coat pocket to lock the door. It's a major hassle since I don't have the "dongle" anymore to attach the card to my keys.

How many times do I have to bring the car into the dealership and lose time out of work and deal with all those hassles, for a "convenience" item that is a major pain in the ass when it doesn't work?
 

·
Registered
Joined
·
592 Posts
yep rear bumper antenna was the problem. took an hour for the dealer to fix.
 

·
Registered
Joined
·
1,139 Posts
I had the red light flash on me but it turned out that the key was right next to my cell phone. Same thing happens if I try to use the request button and my key is in the same pocket as my cell. Keep that in mind guys. Also flashing red doesn't mean low battery, flashing GREEN means low battery, red means that the key is out of range or something's messed up.
 

·
Registered
Joined
·
6,771 Posts
Yeah, this was an issue for me last winter. It seems as though the cold weather brings out this problem. My service shop told me the issue is the antenna under the rear bumper is not adequately protected from the elements. I have not yet experienced the problem yet this year so perhaps teh replacment antennas are better suited for the elements.
 

·
Registered
Joined
·
1,477 Posts
Yeah, this was an issue for me last winter. It seems as though the cold weather brings out this problem. My service shop told me the issue is the antenna under the rear bumper is not adequately protected from the elements. I have not yet experienced the problem yet this year so perhaps teh replacment antennas are better suited for the elements.[/b]
There not. My rear antenna was replaced. My rear replacement switch was replaced. The entire control module (next to the dead pedal) was replaced.

My red "KEY" light is still on. :goon:

Thank goodness I will not own this vehicle after the warrantly expires. Little things like this will be big issues on this vehicle, and fixing them will be expensive and on the dime of the owner.
 

·
Registered
Joined
·
4 Posts
Mine took a couple months before the light came on, but I new for quite some time before that there was a problem. When locking the door using the button on the outside, it would often delay and I would walk away (like 10 feet) then walk back and it would finally lock. Eventually it all stopped working. I had it replaced and it was flawless ... until now. I'm having those unusual delays (both advanced keys, 1 rarely used so its not the battery in the thing). I'm willing to bet I'll need the piece replaced again. They originally though it was something to do with the trunk sensor, but was something else although I don't recall what it was. I'm going in for service next week and will get an update on what exactly was replaced. I'm not too happy this is the second time it seems to be going in less than 2 years. Other than that ... car is fantastic.
 

·
Registered
Joined
·
862 Posts
Brought back from the dead.

Looks like I'm making a trip to the dealership soon. The red KEY light is on and and all my request buttons stopped working. The buttons on the FOB work and the remote can start the car...odd stuff.

I almost feel bad for my dealership though, I've had so much work done for free because Mazda's stuff keeps breaking on me.
 

·
Registered
Joined
·
1,484 Posts
Brought back from the dead.

Looks like I'm making a trip to the dealership soon. The red KEY light is on and and all my request buttons stopped working. The buttons on the FOB work and the remote can start the car...odd stuff.

I almost feel bad for my dealership though, I've had so much work done for free because Mazda's stuff keeps breaking on me.[/b]
Funny, I just had the exact same problems fixed... replaced keyless system rear antenna.

Don't feel bad for the dealership-- everything they do under warranty is paid for by Mazda. The service department always gets paid for their work. The only difference is that under warranty, Mazda pays the bill rather than the car owner.
 

·
Registered
Joined
·
19 Posts
Add me to the list of people with a keyless entry problem. The "red key light" is on and the exterior buttons don't work, but the keyless ignition does work as do the buttons on the key FOB. I am hoping that replacing the rear bumper antenna will fix my problem as some of you have mentioned above. My dealer has been really shitty about honoring my warranty in the past but all I have is a CAI so I am not sure how they are going to say that a CAI caused this problem :).

-s3&6

EDIT: Turns out this was caused by the antenna in the rear bumper. Seems like this is a common problem, I hope it doesn't continue to happen.
 

·
Registered
Joined
·
4,099 Posts
If you get the red "KEY" light always on while the car is on that is a bad sensor as mine comes on when I had the sensor unplugged. Now door is put back together and when engine is off I get the red car symbol with a key in the middle blinking constantly when the engine is off. I wish someone would tell me what that meens...
 

·
Registered
Joined
·
1,041 Posts
Like Indy mentioned, this was a cold weather issue for me as since it's warmed up it's been fine. I think it's either the cold or maybe snow and ice builds up around the sensor in the back bumper making it ineffective.
 

·
Registered
Joined
·
136 Posts
mine started doing this now since i just installed my gauges?
 

·
Registered
Joined
·
54 Posts
My red-key light is on from time to time too, and the trunk button doesn't work sometimes, and the auto-lock doesn't work sometimes...
I figured it was the key-battery, but apparently there is more to it.
Thanks for the antenna info guys, now i need to start thinking of warranty issues i need resolved.
 

·
Registered
Joined
·
2 Posts
having the exact same problem on my new 2009 Mazda9 with 200 miles on it! I just start to notice it's always on. but the advance key otherwise works fine though. yes I'll take it to the dealership to take a look, but wtf.
 

·
Registered
Joined
·
4,099 Posts
QUOTE (aviator79 @ Apr 22 2008, 12:25 PM) index.php?act=findpost&pid=1329886
If you get the red "KEY" light always on while the car is on that is a bad sensor as mine comes on when I had the sensor unplugged. Now door is put back together and when engine is off I get the red car symbol with a key in the middle blinking constantly when the engine is off. I wish someone would tell me what that meens...[/b]
I still have this problem...
 

·
Registered
Joined
·
126 Posts
And back from the dead...
Just had this happen to me today. I've had the rear bumper sensor replaced once for the system not working. Anyone have any idea how expensive the sensor is (I'm out of the 12,000 warranty)?
 

·
Registered
Joined
·
4,099 Posts
should still be covered under normal warrantee. Place to BUY oem MAZDA parts is in the FAQ.
I still have a red blinking car with a key in it. Not sure whats wrong...
 
21 - 40 of 48 Posts
Top