Mazda 6 Forums banner

1 - 20 of 48 Posts

·
Registered
Joined
·
137 Posts
Discussion Starter #1
Yeah well my "KEY" icon lit up solid red two days ago and remains on while driving or having the key at ACC.

The weird thing is every feature of the advance keyless function is still working fine.....??? Does it with both keys....

Has anyone else had this happen? :huh:

I have an appointment at the dealer this friday but thought I'd check with you guys in the mean time. BTW I have a compustar pro alarm-remote starter installed for almost 3 months and that too still works fine. Probably related?

Thanks!
 

·
Registered
Joined
·
862 Posts
Here's a clip from the owners manual:

When the KEY warning light (red) remains illuminated

The advanced key is malfunctioning. Park the vehicle in a safe place, and use the auxiliary key to continue
driving the vehicle. Have the vehicle inspected at an Authorized Mazda Dealer as soon as possible.
 

·
Registered
Joined
·
137 Posts
Discussion Starter #5
Here's a clip from the owners manual:When the KEY warning light (red) remains illuminated The advanced key is malfunctioning. Park the vehicle in a safe place, and use the auxiliary key to continuedriving the vehicle. Have the vehicle inspected at an Authorized Mazda Dealer as soon as possible.[/b]
Thanks, but I already checked the manual and that really did not satisfy me as an answer... Like what kind of malfunction could it be? :huh: I'm having a hard time getting used to use a key to start my car...! :)
Mine is having the same issue about half the time now, it happens whenever its really cold out for me.[/b]
it's been pretty cool lately but not that much..... I've been through much colder for much longer periods of time before....Just hope they can fix it easily....
 

·
Registered
Joined
·
862 Posts
I'll look at my workshop manual after work today and try to dig up some more info. You might be able to pull the code out of the system with AE or a DashHawk.


Someone from mazda needs to "leak" the software for their WDS system, lol j/k
 

·
Registered
Joined
·
592 Posts
mines red to but i know mazda will find some excuse to void my warranty lol so if they fix yours let us know what was wrong
 

·
Registered
Joined
·
1,056 Posts
anyone know how to change the batteries?>
 

·
Premium Member
Joined
·
1,546 Posts
Yeah well my "KEY" icon lit up solid red two days ago and remains on while driving or having the key at ACC.

The weird thing is every feature of the advance keyless function is still working fine.....??? Does it with both keys....

Has anyone else had this happen? :huh:

I have an appointment at the dealer this friday but thought I'd check with you guys in the mean time. BTW I have a compustar pro alarm-remote starter installed for almost 3 months and that too still works fine. Probably related?

Thanks![/b]
Does your trunk request button work? I had the same issue a year ago with the trunk request button not working and the dealer replaced the connector in the rear. This year, I don't have the red key illuminated but my rear trunk has stopped working again. I have an appointment this Firday as well.
 

·
Registered
Joined
·
28 Posts
Mine started doing that (stays on constantly) when I had my windshield replaced and it leaked water inside under the dash. Weird thing is mine goes out when I turn the parking brake and headlights on. Comes back on when I turn them off. Car goes in again tomorrow to have them try and reseal the windshield again. If they can't, they are replacing the whole thing with a new one.
 

·
Registered
Joined
·
137 Posts
Discussion Starter #13
Did you try to replace the battery?[/b]
Negative....but isn't suppose to be a flashing icon to report a low battery?
Plus I tried with my second key wich had been sitting in my drawer since day one.....

I'll look at my workshop manual after work today and try to dig up some more info. You might be able to pull the code out of the system with AE or a DashHawk.
Someone from mazda needs to "leak" the software for their WDS system, lol j/k[/b]
mmmmm.....will definitely try that tomorrow

mines red to but i know mazda will find some excuse to void my warranty lol so if they fix yours let us know what was wrong[/b]
For sure I'll give an update after my appointment friday

Does your trunk request button work? I had the same issue a year ago with the trunk request button not working and the dealer replaced the connector in the rear. This year, I don't have the red key illuminated but my rear trunk has stopped working again. I have an appointment this Firday as well.[/b]
Yep all two front door and trunk button still working normally. Hell even the auto-lock feature is flawless.....
In the mean time I'll continue my head scratching!
I think it is a correct assumption that Mazda's keyless system is far from perfect as a 1st generation (or is it?). This forum has it's share of owners reporting glitches and malfunctions...
 

·
Registered
Joined
·
21 Posts
i had this problem months ago. Dealer traced root cause to a faulty antenna located under the rear bumper. It was replaced and the problem was resolved.
 

·
Registered
Joined
·
76 Posts
i had this problem months ago. Dealer traced root cause to a faulty antenna located under the rear bumper. It was replaced and the problem was resolved.[/b]

I had this done last week due to the exact same issue.
Something that I cant quite understand is while the red KEY was lit I suddenly was unable to move the shifter into and out of 1st and 2nd gear without a heavy amount of force. Its like they became locked out bc of the malfunction. Once the antenna was replaced the issue was resolved.
 

·
Registered
Joined
·
137 Posts
Discussion Starter #17
Short update:
It was indeed the trunk antenna that needs to be replaced. Seems an intermittent problem since the trunk button was still working....
They told me it was no problem using the keyless to start the car until the part was ordered and replaced, which suits me just fine.
Plus I'm getting warranty work done: wheel bearing replacement and brake rotor change for the rear....
 

·
Registered
Joined
·
592 Posts
Short update:
It was indeed the trunk antenna that needs to be replaced. Seems an intermittent problem since the trunk button was still working....
They told me it was no problem using the keyless to start the car until the part was ordered and replaced, which suits me just fine.
Plus I'm getting warranty work done: wheel bearing replacement and brake rotor change for the rear....[/b]
mine is steady on and none of the buttons work. keyless start still works no problems and can hit lock/ unlock on key fob to make it work. auto lock feature dont work either. gonna call dealer today to see what excuse mazda will come up to void my warranty with this issue lol.... Motor/drivetrain voided already
 

·
Registered
Joined
·
2,276 Posts
Same problem here....just got it fixed from the dealership yesterday and everything is working perfectly. I sure did miss the auto locking feature and pressing the door handle button to lock or unlock. Viva la Mazda!! :love:
 
1 - 20 of 48 Posts
Top