Mazda 6 Forums banner
1 - 9 of 9 Posts

·
Registered
Joined
·
32 Posts
Same problems after I got the bluetooth module replaced today. 1/1 on songs, can't see any playlist, artists, song lists, anything. It does start up quickly but I need the playlists! I'll drive it for awhile and hopefully it fixes itself like you guys.
 

·
Registered
Joined
·
32 Posts
New Development: Finally got it working so well. Had a proper song count, playlists, and a song list. But lo and behold when I turn the car off and come back in, back to 1/1 with no playlists and unable to shuffle. I'm thinking that a good road trip would be good for it as it takes a while to load to perfection and I only drive 20 minutes to work/class.
 

·
Registered
Joined
·
32 Posts
So, I had my dealership install the new Blue Tooth Module a couple days ago, TSB is # 09-008/15. While it is an improvement, it isn't perfect. I tested on both my iPods, a 16 gig Nano and a 160 gig Classic. Results are the same for both, with the only difference being that it doesn't hate the Classic anymore.
I have found that from starting the car, when first connecting both iPods, it did start playing at track 1, and called it 1 of 1. But it would play all songs, but didn't show playlists. Eventually though, it did show the correct number of songs and play lists. Also, initially, it froze a couple times and skipping tracks lagged, but these hiccups eventually righted themselves. Also, for a few hours, when getting in an out of the car, the system will pick up where it left off on the song I was listening to, but if the song is in a playlist, it would not continue on in that playlist. After an extended period of time though, like over night, when I start the car first thing in the morning, the iPod will start playing from track one again.
One thing I did notice though. From day one of obtaining this car, I have had the display et to Auto for nite/day dimming, it never funtioned properly, and always stayed at the Daytime setting. This does now seem to work properly.
I have the same issue. I just got the tsb done today and if I'm listening to a playlist and shut the car off, it won't start from where I left off.

However, if I'm listening to just song tracks outside of a playlist, it will return to the same song once I turn the car back on.

Kind of useless since I have a lot of playlists and that's how I listen to my music the majority of the time.

It's pretty sad that my old 2011 Sonata ipod hook up worked flawlessly.
Also sad that my wife's old FRS, a "sports" car, started the iPod right where it left off without missing a beat. Even sadder was I was test driving a 16 yesterday and although it worked very well, it eventually froze up which makes me feel they really don't care about this problem much.
 

·
Registered
Joined
·
32 Posts
I have the same problem but the worst aspect of the system is that once downloaded, the software will not allow you to play Playlists even though it presents your Playlists on the screen. As soon as you try to activate a selected Playlist, it starts at the beginning of your total track list. I am sick of hearing "Adele"!!! Artists or songs pose no problem but playing Playlists whick is the thing I want to do most is impossible.
Yup trying to play playlists is the worst. I hate this thing and such a nagging problem on an otherwise great car. This is the kind of thing that will keep me from becoming a Mazda fanboy.
 

·
Registered
Joined
·
32 Posts
WOOOOWWW. This is just crazy. I had the bluetooth module installed as well and it made it better and worse (????) Ipod starts right up pretty quickly to a 1/1 count until it finally loads all the songs (which becomes the same amount of time it took to load in the first place). Once its loaded, it shows no playlists but the VR Playlist (again, ????) This has put a huge stain on Mazda for me that I don't think I can overlook in the future.
 

·
Registered
Joined
·
32 Posts
So I got the latest bluetooth module as well and it is working almost completely as it should. Sometimes it still doesn't show all my playlists, and if you're playing a song from a certain playlist, when you start the car the songs start at the very beginning of the iPod at least for me. Music does start playing almost right away so that's good. I guess this will have to do.
 

·
Registered
Joined
·
32 Posts
I'm not an Apple user, but my Sony mp3 player had this setting so maybe it's similar. Somewhere in your settings there may be a 'USB CONNECTION MODE'. Make sure it's set to STANDBY. That helped me out, as being on STANDBY mode allows the player to retain the last song played instead of resetting to Track 1 every time. You still have to remember to hit SHUFFLE again but at least you don't hear the same song every time you start up.
Hm I'm not sure if it has that but I will definitely check it out because that would help immensely. Thanks for that!
 

·
Registered
Joined
·
32 Posts
I would say do it. It only plays the 1st song if I play from playlists (which sucks cause I do all the time). But I would do it just for how fast it starts up now. And my dealership is a pain when it comes to doing any warranty work. I have to print out the TSB and bring it in just for them to do the work.
 

·
Registered
Joined
·
32 Posts
iPod doesn't work at all now. It just shows Kendrick Lamar - A.D.H.D. at the 3:34 mark and doesn't move. This is one of those things that will keep me from ever getting another Mazda and dumping the one I have as soon as I can.
 
1 - 9 of 9 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top