Mazda 6 Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
81 Posts
Discussion Starter #1
Anyone know how to replace the purge valve solenoid on a 2003 6S ATX? I am getting the 0441 code and was told it was that part.

Thanks
 

·
Registered
Joined
·
900 Posts
Sure that you did not leave your gas cap loose?
Other possibilities:
Bad vacuum switch
Broken or damaged EVAP line or canister
Open in PCM purge command circuit
Open or short in Voltage feed circuit to Purge Solenoid
Restriction in EVAP solenoid, line or canister
Corrosion or resistance in purge connector

Also, if it's been cold where you are moisture could make the purge valve stick. I'd check the cap, clear the fault and wait and see if light comes back. The EVAP canister purge solenoid valve is under the hood on the drivers rear of the intake manifold area (I think...).
 

·
Registered
Joined
·
81 Posts
Discussion Starter #3
I've been having this problem for some time, and I'm pretty sure its not the gas cap. I cleared the code and tightened the gas cap and it came back. The recommendation of the dealership was to replace the solenoid. Of course with this code there are a lot of possibilities it could be. Hell, I'm on my second gas cap cause the first one broke and went bad.
 

·
Registered
Joined
·
181 Posts
QUOTE (SeeMeZoomZoom @ Feb 17 2010, 02:50 PM) index.php?act=findpost&pid=1637732
I've been having this problem for some time, and I'm pretty sure its not the gas cap. I cleared the code and tightened the gas cap and it came back. The recommendation of the dealership was to replace the solenoid. Of course with this code there are a lot of possibilities it could be. Hell, I'm on my second gas cap cause the first one broke and went bad.[/b]

where did you get your gas cap?
 

·
Registered
Joined
·
81 Posts
Discussion Starter #5
1 - 5 of 5 Posts
Top