Mazda 6 Forums banner

1 - 12 of 12 Posts

·
Registered
Joined
·
38 Posts
Discussion Starter · #1 ·
The last week or so, my fans keep running about 20-30 sec after my car is turned off...and it's also really loud in the car at times....plus when I'm using my cruise control, u can feel the car jerking. Kind of feels like u fooling around and pressing then releasing the throttle....possible ECU probs? Do I need to have the computer reflashed???


Sent from my Autoguide iPhone app
 

·
Registered
Joined
·
944 Posts
20-30 seconds of fan running is not too bad (especially if its hot) if you notice it getting longer the fan relay module is going out (replaced mine a couple of times)....but thinking its the module (due to loudness), eventually the fans will continue to run until battery is dead or fans burn out.....yeah.
With the pulsing, try cleaning the MAF, check plugs and COPs (again..I know) almost sounds like you are about to start misfiring again. Hope this helps ya out.
 

·
Registered
Joined
·
2,736 Posts
Fan relay.....and like monkey said, clean the MAF.
If not, the COP's.....):
 

·
Registered
Joined
·
38 Posts
Discussion Starter · #5 ·
I really hope it's not the coils going bad again. The fans never did run after the car was turned off no matter how hot it was...that what freaked me out. Even when my car is running for 5 minutes and I turn it off, it keeps running....


Sent from my Autoguide iPhone app
 

·
Registered
Joined
·
944 Posts
yeah the fans have never before (after turning off the car), I would def. say the fan relay is going.
Not a bad suggestion to check the vac. lines (good lookin' out tenchix)
 

·
Registered
Joined
·
38 Posts
Discussion Starter · #10 ·
Thanks guys!! Hope I can fix this before the fans burnout and I have to pay more for repairs


Sent from my Autoguide iPhone app
 

·
Registered
Joined
·
38 Posts
Discussion Starter · #11 ·
Haven't been on here in a while...it was the relay thAt was causing the issues...thank goodness it was just that!


Sent from my Autoguide iPhone app
 

·
Registered
Joined
·
32 Posts
my car is having this problem as well...sorry I'm a noob at this sort of thing...where exactly is the fan relay located?

hey Mazda6gyrl it's been a while!!!
 
1 - 12 of 12 Posts
Top