Mazda 6 Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
104 Posts
Discussion Starter #1
OK, tonight I park my 2004 6 Wagon at a movie theater and I go back to get something out of the car, and the second I flip the power door lock switch the panic alarm goes off, horn honking on and off and hazards flashing. Here's the thing--I DON'T HAVE AN ALARM IN THE CAR! I do have a panic button on the remote that triggers the horn/flashers, but I don't even carry the remote, it was home in my desk drawer.

Starting the car didn't stop the alarm. I opened the hood to look for the fuse but after about 5 minutes it finally stopped on its own, only to start again as soon as I slammed the hood shut. I reopened the hood and disconnected and reconnected the battery hoping to reset the car's computer, but each time I connected the power back the alarm started again.

After finally pulling the horn fuse, I drove home with the blinkers flashing as the (now silent) alarm continued. Every 4 or 5 minutes the alarm would time out and stop, but if I locked and unlocked the power doors once or twice it would go off again.

I got home and pulled the battery terminal and will take it to the dealer tomorrow, but I was wondering if anyone else has ever heard of this problem. It seems like something in the brain must have gone wacky.
 

·
Registered
Joined
·
5,217 Posts
All Mazda6s have alarms. You just don't have the optional upgraded alarm.

But that's something the dealer needs to look at I guess. The upgraded alarm has a sensitivity adjustment for these sort of problems. I have no idea where that adjustment is on the stock factory alarm.
 

·
Registered
Joined
·
1,197 Posts
i have the optional alarm by mazda...i have a kill switch on the inside by my left leg....i have to hold that and switch and turn the key into the "on" position to make the alarm shut off....

and i i have the same thing where you take the negative terminal off and put it back on and it goes off until i kill it.
 

·
Registered
Joined
·
36 Posts
OK, tonight I park my 2004 6 Wagon at a movie theater and I go back to get something out of the car, and the second I flip the power door lock switch the panic alarm goes off, horn honking on and off and hazards flashing. Here's the thing--I DON'T HAVE AN ALARM IN THE CAR! I do have a panic button on the remote that triggers the horn/flashers, but I don't even carry the remote, it was home in my desk drawer.

Starting the car didn't stop the alarm. I opened the hood to look for the fuse but after about 5 minutes it finally stopped on its own, only to start again as soon as I slammed the hood shut. I reopened the hood and disconnected and reconnected the battery hoping to reset the car's computer, but each time I connected the power back the alarm started again.

After finally pulling the horn fuse, I drove home with the blinkers flashing as the (now silent) alarm continued. Every 4 or 5 minutes the alarm would time out and stop, but if I locked and unlocked the power doors once or twice it would go off again.

I got home and pulled the battery terminal and will take it to the dealer tomorrow, but I was wondering if anyone else has ever heard of this problem. It seems like something in the brain must have gone wacky.
Did you ever find out how to fix this problem I have this exact same problem and can't find out how to fix it
 

·
Registered
Joined
·
2,660 Posts
Could be as simple as a low battery or a bum door, hood, or hatch switch. Look in and confirm the door ajar light is off. If so, walk around and PULL OUT on all surfaces. One thats marginal in adjustment may trigger, so the goal here is to see if you can do it by prying out on the panels.
 

·
Registered
Joined
·
5 Posts
I had this happen once when I would only use the key fob to lock and unlock the doors. After being embarrassed at the gas station I finally inserted the key in the door and locked, then unlocked the door and it stopped.
 
1 - 7 of 7 Posts
Top