Mazda 6 Forums banner

1 - 9 of 9 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
So I need some help. I’ve changed both cats to brand new ones. Replaced all 02 sensors. And now I have these codes to bank 1 sensor 2. I’ve changed the same 02 twice. Checked all the wiring for any damages and nothing. I’m stuck. Any ideas?
 

·
Registered
Joined
·
6 Posts
Discussion Starter #2
So I need some help. I’ve changed both cats to brand new ones. Replaced all 02 sensors. And now I have these codes to bank 1 sensor 2. I’ve changed the same 02 twice. Checked all the wiring for any damages and nothing. I’m stuck. Any ideas?
By the ways it’s a v6 3.0
 

·
Registered
Joined
·
461 Posts
And I guess you don't have the ones you removed? If yes, put those back.
Here is some good literature about your issue: P0037
And here is what is in the Workshop Manual about how to test your sensors.

237995

237996
Capture.JPG
Capture1.JPG
 

·
Registered
Joined
·
6 Posts
Discussion Starter #7
Yes I do have them. But they went bad so I replaced. But thank you for the information .
 

·
Rally Racer
Joined
·
1,979 Posts
Yes I do have them. But they went bad so I replaced. But thank you for the information .
How do you know they went bad? You mentioned no codes before?
Also when you say both cats (4cyl) the 6-cylinder has 4 catalytic converters. I am guessing you only replaced the front (upstream/manifold) ones?
Did you fix the condition that caused the failure of your cats to begin with? This is generally the Coil-On-Plug and Spark Plug with the v6.

If the Code clears with the old O2 sensors then you likely have incorrect parts. If it persists then something was done while installing the cats, (wire crush, not connected properly, etc...)
 

·
Registered
Joined
·
6 Posts
Discussion Starter #9
It’s a v6. Originally I had a cat codes so I replaced both. The honeycomb inside had holes so I replaced both headers. Front and back. Since I did that I went along with replacing the 02 sensors all four. And the only code that came on was p0037,p0140 for bank 1 sensor 2.
 
1 - 9 of 9 Posts
Top