Mazda 6 Forums banner

1 - 11 of 11 Posts

·
Registered
Joined
·
30 Posts
Discussion Starter #1
Just a lesson learned post in the hope it will save someone some hassle. 2014 touring m/t has 174k+ miles on it and I just had to replace the upstream o2 sensor. Before that I mistakenly replaced the pcv valve. Apparently the vacuum pull on these is lower than I'm familiar with for older vehicles. Code was a P0171 and came with a rough idle (actually stalled itself a few times) and hesitations and surges anywhere from idle to about 3000rpm. Above that it was more cyclical. As in if trying to cruise at 70 mph it would do more 65-70-65-70...If it happens to you unhook the 02 Sensor and go for a drive. If it fixes the issues the new sensor is what you need. NTK 24369 appears to be same as oem with same length, color, plug, and everything. Actually got mine from autozone for $125 because they could get it in 2 days. Hope this helps somebody!

Sent from my ONEPLUS A5000 using Tapatalk
 

·
Registered
Joined
·
30 Posts
Discussion Starter #3
Thx for sharing. As for your car with 174k miles: impressive! Can you recount to us any other prbs encountered?
Besides regular maintenance(engine oil, trans oil, brakes, plugs 100k, coolant flush 105k). I did the belts, tensioner and water pump around 130kish because the accessory belt snapped not the water pump belt but "while you're in there. " Replaced front wheel bearings (Probably because I drive on construction sites for work. Probably not a big wear item for regular commuters. )

Sent from my ONEPLUS A5000 using Tapatalk
 

·
Registered
Joined
·
31 Posts
Besides regular maintenance(engine oil, trans oil, brakes, plugs 100k, coolant flush 105k). I did the belts, tensioner and water pump around 130kish because the accessory belt snapped not the water pump belt but "while you're in there. " Replaced front wheel bearings (Probably because I drive on construction sites for work. Probably not a big wear item for regular commuters. )

Sent from my ONEPLUS A5000 using Tapatalk
driving on construction sites, did you replace the structs or any suspension components? steering components? any weird noise when you turning the wheel?
 

·
Registered
Joined
·
30 Posts
Discussion Starter #5
Knock on wood but no. No struts, shocks, control arms, ball joints, etc. Probably not as quiet as the day I bought it but nothing has shown enough play to warrant replacement.

Sent from my ONEPLUS A5000 using Tapatalk
 

·
Registered
Joined
·
31 Posts
Knock on wood but no. No struts, shocks, control arms, ball joints, etc. Probably not as quiet as the day I bought it but nothing has shown enough play to warrant replacement.

Sent from my ONEPLUS A5000 using Tapatalk
Sorry about too many questions.
Do you have any issue on carbon buildup? or have you done any maintenance against carbon on intake valve?
 

·
Registered
Joined
·
30 Posts
Discussion Starter #7
Sorry about too many questions.

Do you have any issue on carbon buildup? or have you done any maintenance against carbon on intake valve?
Lol. It's fine. I realize I'm a bit of a Guinea pig with this engine. Honestly, aside from a gas treatment every now and then(amsoil) (definitely not with any regularity) I've done nothing special. Maybe b every 30k on average. If there is buildup in there it's not affecting power enough for me to notice. I haven't been in there to check officially. If it's something that I've done that is contributing to my success my guess would be amsoil signature oil with their filter? 10k-12k change intervals. I also forgot to mention in my first maintenance that I did have the entire brake system bled at 100k as well and intend to again at 200k.

Sent from my ONEPLUS A5000 using Tapatalk
 

·
Registered
Joined
·
31 Posts
Wow! Close to 200,000 miles.

If I may stray from the topic, how many times have you changed the transmission oil?
that is good question I guess. since Mazda says life time transmission fluid, there are not quite a lot of people change it. but I own a Acura TL as well, I change transmission fluid every 20k miles. but not filter change for it.
I plan to do the transmission fluid for my 6 as well, but I am not sure if I need to change the filter, that is in the pan
 

·
Registered
Joined
·
30 Posts
Discussion Starter #10
Only once at 50k. The whole quart with red line. Manual trans here though.

Sent from my ONEPLUS A5000 using Tapatalk
 

·
Registered
Joined
·
64 Posts
Dang man, I changed mine a ~15K, ~50k, and 110K with redline MTF. I originally thought that it was just cheap maintenance; it costs less than an oil change. I think I'll stick with the 60k interval and do 170k next time! For the record, I have a 14 sport 6mt.
 
1 - 11 of 11 Posts
About this Discussion
10 Replies
5 Participants
neonoggie
Mazda 6 Forums
Mazda6club.com is a forum dedicated to the Mazda6 / Atenza. Come and discuss reliability, performance, modifications, and more!
Full Forum Listing
Top