Mazda 6 Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
05 model 2.3l auto tranny

Recently I've started to get an oil light, and some engine noise. I noticed it when I pulled up to park, there was the oil light and a strange noise coming from the engine. It's hard to describe the sound, but I would say a rough rattling. What could this be? I'll be taking it in but I'm freaking out here.
 

·
Registered
Joined
·
50 Posts
you should be freaking out. that happened to me. except i didn't get a light. turns out the bearings in the bottom end of these engines are aluminum. lose oil pressure, or overheat the oil and it's over. you've most likely spun a bearing or melted it.

the shop you take it to will have to pull the engine to have the crank and rods polished and sized for the new bearings.

i just got mine back from the shop today and now i have some issues. a/c doesn't work. idle is erratic. engine light is on. it's something about the neutral/park switch.
 

·
Registered
Joined
·
3 Posts
mines in at the dealer right now for the same thing spun all the rod bearings but they still havnt told me where the oil went i only had 1k on the oil since last change
 

·
Registered
Joined
·
50 Posts
Been a while since i was on here last. The shop fixed most of my problems from after they reinstalled the engine. turns out they had stuff plugged in in the wrong places and some not plugged in at all. Don't really understand how they would fuck that up. most plugs don't just fit into each other, they're only to go in one spot. But even if there are alot of harnesses that can fit together, they really should have labelled them all before pulling things apart. maybe that's just me though.
I still don't understand what happened to my oil either. How does oil just disappear? In my case i had 3000kms on the last oil change and had checked the level about one week before i had problems. I also tracked it(drag strip) between the time i checked the oil and the time i had engine noise. I understand that this engine does use some oil with the vvt but it really shouldn't use ALL of it, even if I did hit the track!
I hope your situation worked out for you!
 
1 - 4 of 4 Posts
Top