Mazda 6 Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
23 Posts
Discussion Starter · #1 ·
To all CPE header owners awaiting the O2 sensor extension wire replacements, your wait is ....almost over. Recently my car was used as the test car for CPE so they could get the length and connector fit correct. I have had the test pair on for five day's now and NO CEL's so far. CPE say's that they should be ready for distrubution of the sensor wires in 2-3 weeks. They want to be sure no CELs pop up. Sorry for the long wait to tell everyone.
 

·
Registered
Joined
·
1,813 Posts
good, news. almost there!!!!
 

·
Registered
Joined
·
578 Posts
I'm glad they will be available soon. That's the only thing that kept me from installing my headers. I will still probably wait until spring to do the install. At this point, another 6 months makes little difference anyway...

Does anyone know how the distribution of the extensions will work? Do we have to contact CP-E directly, or are they just going to send them to anyone who bought the headers?
 

·
Registered
Joined
·
578 Posts
You should post this in the original thread.

http://forum.mazda6club.com/index.php?showtopic=61006

I paid CASH for my O2 extensions since my seller "forgot" to include those... not sure how it will work for others that bought theirs new.
[/b]
You beat me too it. I was just heading over there to do that as I originally started that one. I figured maybe the starter of this thread might know too though.
 

·
Registered
Joined
·
297 Posts
Well...it's about time...now, since I spliced through the original wires, I wonder if that would affect the system...too bad I couldn't wait to install it...by any chance, for all those who installed their headers, how are the nuts and bolts holding?...mine broke off a couple of months ago and had to replace it...
 

·
Registered
Joined
·
1,320 Posts
my nuts and bolts are holding up fine... you probably overtightened them.
 
1 - 7 of 7 Posts
Top