Mazda 6 Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
I have been having problems starting my 2003 Mazda 6. the Battery, engine, and starter are all new. When I turn the key it won't crank even though the battery seems fine. The dealership replaced the starter and an electrical relay and the car seemed fine for about a day and a half. Now When I prime it to start I can't hear the fuel pump and the engine and the battery light come on.

Here is the wierd part. Randomly, while in the prime position, the engine and battery light will flicker and then go off. Then the Temperature gage will move as if there is actually power getting to it. The car will still not start like this, and a few seconds later the warning lights will come back and the temp gage will go back to bellow C.

It's an intermitten problem so the dealer ship can't duplicate and won't fix it. This is the 4th time I have brought it in for the same problem.
 

·
Registered
Joined
·
508 Posts
I have been having problems starting my 2003 Mazda 6. the Battery, engine, and starter are all new. When I turn the key it won't crank even though the battery seems fine. The dealership replaced the starter and an electrical relay and the car seemed fine for about a day and a half. Now When I prime it to start I can't hear the fuel pump and the engine and the battery light come on.

Here is the wierd part. Randomly, while in the prime position, the engine and battery light will flicker and then go off. Then the Temperature gage will move as if there is actually power getting to it. The car will still not start like this, and a few seconds later the warning lights will come back and the temp gage will go back to bellow C.

It's an intermitten problem so the dealer ship can't duplicate and won't fix it. This is the 4th time I have brought it in for the same problem.
[/b]

Go to another dealer, keep trying, or take it somewhere else and find out whats going on.
 
1 - 4 of 4 Posts
Top