Mazda 6 Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
I just replaced my bad engine with a JDM one that I have ordered recently.

I dressed the jdm engine with all the proper sensors and pieces to make it identical with the usdm engine. I did double checked every single connector from the wiring harness and they are all pluged in.

I trying to start the car but it doesn't start.

The engine crank well , it seems to want to start but dies instantly.

I double checked the spark plugs , they seem fine and they were working in the old engine.
The coil is ok.
Gaz in each cylinders.

I was wondering if those car need a base map reset in the ecu or any pre-setting need to be injected into the ecu.

I have done many Honda swap but this is my first Mazda.

Any one can help me out , please !

Between , the car was running but it had a rod bearing problem . It took me about 3 days to change the engine. I guess the ECU was reseted...
 

·
Registered
Joined
·
2 Posts
Discussion Starter #2
I have figured out the problem.

I will post some pictures because it might happen to one of you sooner or later.

The intake cam has a cam angle sensor located to the back of the engine.

The usdm engine that was originally installed in my Mazda 6 was equipped with 5 tooth as a reference for the sensor.

The JDM engine that i received had only 1 teeth at the end of the cam.

So it means that the calibration of the cam angle sensor is different between JDM and USDM PCM.

I have swapped the cams.

Voilà, Problem solved.

Merci
 

·
Premium Member
Joined
·
9,080 Posts
i believe the focus cams only have the one tooth...wonder if the jdm guys can swap out their cams then?

good info
 
1 - 3 of 3 Posts
Top