Mazda 6 Forums banner

1 - 12 of 12 Posts

·
Registered
Joined
·
18 Posts
Discussion Starter #1
I just purchased a 2006 Mazda6 GrandSport s, and am still getting accustomed to some idiosyncracies about the car. I do have a couple questions regarding some weird quirks that haven't been asked by anyone which makes me somewhat concerned...

1) When I start the car and it's cold, the RPM's will quickly rev up to about 2k for about a minute or so. After that time, it will go back to about 1k where it should be. Is this normal?

2) When the engine is hot and I turn the car off, there is a buzzing noise coming from the engine. This lasts for approximately 2 minutes, and then it shuts off. Is this part of the cooling down process?

Thanks in advance.
 

·
Registered
Joined
·
6,771 Posts
#1 - Yes.

#2 - Not quite sure what you mean by buzzing. It could be the cooling fans still operating.
 

·
Registered
Joined
·
18 Posts
Discussion Starter #3
#1 - Yes.

#2 - Not quite sure what you mean by buzzing. It could be the cooling fans still operating.
[/b]
Thanks. It doesn't appear to be a fan. I tried opening the hood after it happened last time, and it sounded like it was coming directly from the engine block. Then, the sound quickly disappated before I could tell where it was coming from.
 

·
Registered
Joined
·
6,771 Posts
Was it more of a hum than a buzz? If it's a hum, then it's probably the computer doing it's emissions test thing.
 

·
Registered
Joined
·
18 Posts
Discussion Starter #5
Was it more of a hum than a buzz? If it's a hum, then it's probably the computer doing it's emissions test thing.
[/b]
Yeah. I guess you can consider it a hum. I was concerned mainly because no one had asked about it before, and it wasn't contained within the owner's manual. Thanks for the prompt response by the way.
 

·
Registered
Joined
·
72 Posts
I just got mine last Thursday and the same thing happened to me yesterday. I was concerned as well as it was Pretty loud. Loud enough for me to question if that was my house's alarm system or my car. I assumed it was nothing to worry about but nice to hear someone else has the weirdness as well.

WhiteThnder-did you hammer on it for the first time?? I did and when I got home I turned it off and it happened
 

·
Registered
Joined
·
18 Posts
Discussion Starter #9
Thanks to everyone for their responses.

I just got mine last Thursday and the same thing happened to me yesterday. I was concerned as well as it was Pretty loud. Loud enough for me to question if that was my house's alarm system or my car. I assumed it was nothing to worry about but nice to hear someone else has the weirdness as well.

WhiteThnder-did you hammer on it for the first time?? I did and when I got home I turned it off and it happened
[/b]
I wouldn't say I hammered on it, but I do have a long commute from work so I figured it was part of the cooling process. It didn't happen to me yesterday though, so maybe it doesn't happen all the time??
 

·
Registered
Joined
·
2,854 Posts
The high RPM when you first start it up is to help warm the car up faster. My old Accord was like that and I was like "WTF"? Then I looked it up in the owners manual and it explained it was to help it warm up.
 

·
Registered
Joined
·
635 Posts
but wont revving it higher do more damage when the oil isnt flowing ? esp in winters ...

or maybe i just dont know how it works .. lol
 
1 - 12 of 12 Posts
Top