Mazda 6 Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
160 Posts
Discussion Starter #1
For the past couple of weeks my car has been leaking some kind of fluid, I think its either water or coolant. Everything else seems normal but the engine has been cold when I start it up lately even when its very hot outside. What should I do?
 

·
Registered
Joined
·
67 Posts
What color is the fluid? coolant will be either lime green or a tang orange (possible purple or pink but not likely for our cars) trans fluid is like a cranberry red, oil is oil.... winsheild wiper fluid....ya
 

·
Registered
Joined
·
1,749 Posts
When do you notice the leak? Is it there even if the car hasn't run? Does it happen as soon as the engine starts? Where does it seem to be leaking from, if you look under the car?
 

·
Registered
Joined
·
160 Posts
Discussion Starter #4
I cant really notice a distinct color or smell of the leak. Its not there if the car hasn't run. It usually happens after I have been driving when the car is off. Its leaking from somewhere near the front wheels. I really appreciate any help with this.
 

·
Registered
Joined
·
67 Posts
Bad thing is all the fluids i named run near the front wheels. Do you have the under engine guard bolted on still? that should catch most of what ever is dripping, if it is up and its still driping check your brake fluid/lines and make sure there not bleeding themselves, if nothing else, get a white cardboard box and drive around awhile, somewhat hard to get a good pressure build up and then park over the flattened white box, this will help see color and will give you an idea of what area its dripping from.

Oil, Brake Fluid, Steering Fluid, Trans Fluid, coolant and winshield wiper fluid. all those are what your looking at, color will be hard to teel since they all can come differently, so look and try to place where it drips, will make it alot easier.
 

·
Registered
Joined
·
160 Posts
Discussion Starter #7
No its not the A/C. But, does the engine being cold have anything to do with this or is that normal?
 

·
Registered
Joined
·
1,749 Posts
Well, it started to sound like condensation from the AC. But...there's no smell or color to it?
 
1 - 8 of 8 Posts
Top