Mazda 6 Forums banner
1 - 13 of 13 Posts

·
Registered
Joined
·
15 Posts
Discussion Starter · #1 ·
Hey all...

As some of you know, we have been building up the Microtech EMS for the Mazda 6i and the Mazda 6S. The 6i unit already works (little hard on 03 and early 04 units... ).

If you have questions or want to discuss it. I wanted to be here to answer questions if you need.

Later,

Steve
 

·
Registered
Joined
·
2,664 Posts
How far along is the V6 unit?

What do you mean by a little hard on 03 and early 04's?
 

·
Premium Member
Joined
·
9,080 Posts
hopefully the V6 is close cause Adam's car went into the shop this past week, so the sooner the tuner comes the sooner the turbo's done!

some ignition/tach issues i believe with the older I4's as they don't use the coil on plug found on the newer ones and the 3.
 

·
Registered
Joined
·
254 Posts
my 05 doesnt use the coil on plug ignition either, its an 8/04 build date though, so they must have switched systems mid-year 05. I'm interested in this, just want to see what happens with this ignition system first.
 

·
Registered
Joined
·
15 Posts
Discussion Starter · #5 ·
The V6 unit I should have an update on early this week. It should hopefully be done before the end of the month.

We will have seperate systems for the coil on plug boys and the non coil on plug boys for both V6 and I4 depending on what is needed etc.

The ignition/tach issues we are having are more due to something funky with the grounding system with the ECU for the sensors. I'm building a workaround soon hopefully.
 

·
Premium Member
Joined
·
9,080 Posts
not that it matter, but i had to use a ford tach driver to get the signal correct using my Haltech. don't know if there is a built in walkaround, but it's a quick fix. and all the V6 guys are coil on plug if that info helps at all.
 

·
Registered
Joined
·
15 Posts
Discussion Starter · #8 ·
not that it matter, but i had to use a ford tach driver to get the signal correct using my Haltech. don't know if there is a built in walkaround, but it's a quick fix. and all the V6 guys are coil on plug if that info helps at all.
[/b]
What did you wire it in to? The tach is driven off the microcomputer embedded in the gauge cluster, so that's why I'm asking/confused.

Thanks!

Steve
 

·
Premium Member
Joined
·
7,221 Posts
Woo, go Steve! Adam's car hasn't been put up on the lift, but it should be getting started this week now the Baja 1000 is over :)
 

·
Premium Member
Joined
·
9,080 Posts
i don't remember off hand what it was connected to, i don't have the car in front of me to look at the moment either. if needed i can break out the install intructions of the turbo and back track the wire color to my schematics to find out for sure what it's tapped off of?

let me know here, or you should still have my email too....or you can email adam and i'll go through him
 

·
Registered
Joined
·
15 Posts
Discussion Starter · #12 ·
i don't remember off hand what it was connected to, i don't have the car in front of me to look at the moment either. if needed i can break out the install intructions of the turbo and back track the wire color to my schematics to find out for sure what it's tapped off of?

let me know here, or you should still have my email too....or you can email adam and i'll go through him
[/b]
Right, my concern is where the output of this device goes. The Microtech has a tach drive internal to it, I'm just curious as to where you guys connected something like that as it may be one way for me to try to get around the minor tach drop problem I'm having on one particular installation on a different app outside of the V6.

On the Protege's it didn't work, I'm curious how it's done on the M6.
 

·
Registered
Joined
·
2,398 Posts
Steve unfortunatly I haven't played with the tach wiring on my car so I am of no help here. My best bet would be to see what bryan did with the haltech and see what we can find
 
1 - 13 of 13 Posts
Top