Mazda 6 Forums banner
241 - 260 of 277 Posts

·
Registered
Joined
·
85 Posts
Point being when you start this process if you want baseline WOT pull logs (and you probably do) for comparison purposes make sure you give the car some time to re-learn after pulling the base ROM dump before you go do those pulls, or you're going to get numbers that are SIGNIFICANTLY down from where they should be. In addition while OVT notes that you need to drive the car for 20 or so miles before logging to send back to him after flashing a new ROM file I'll underline this -- the ECU's adaptive process is VERY material to performance so don't ignore that instruction!
I just did the ROM dump. Maybe it's all in my head, but the car feels much better accelerating from a stop than it ever has. Really it feels better through all the gears (MTX) than it ever has. Did my car learn to be a piece of shit from the PO (or from me) or what?

Edit: When you say ROM dump, are you referring the first copy of the ecu that's made after linking the VIN Key and Device Key? That's the part I just finished, and it sounds like doing that resets the ecu to factory... ?
 

·
Registered
Joined
·
85 Posts
First data log done and sent! Did it on 87. Not sure if I do a separate one on 91 or not... waiting to hear back on that. Either way.. this is way easier to do than I thought it would be. I know I've got a process and probably some finicky driving ahead of me until it's dialed in, but the actual task of plugging in and copying, etc.. way easier and not as stressful as I thought it might be.
 

·
Registered
Joined
·
85 Posts
So I just uploaded the first flash onto the ecu. There's good and possibly bad news.

Good news: after round 1, it already feels better. Better response and pep in the lower rpm range. Downshifting feels a little better too.

Possibly bad news: I'm hearing a slight rattle/knock sound when accelerating immediately after shifting into 2nd or 3rd gears... really only hear it when driving aggressively. Is this is normal? Doesn't seem normal, but the car feels fine and no lights on the dash. I don't want to destroy my car, so just wondering if I should flash back to stock before I drive back to work this afternoon?

Thanks!

Edit: I think to be on the safe side for now I'm going to load the stock file. Don't want to f anything up.
 

·
Registered
Joined
·
5,058 Posts
So I just uploaded the first flash onto the ecu. There's good and possibly bad news.

Good news: after round 1, it already feels better. Better response and pep in the lower rpm range. Downshifting feels a little better too.

Possibly bad news: I'm hearing a slight rattle/knock sound when accelerating immediately after shifting into 2nd or 3rd gears... really only hear it when driving aggressively. Is this is normal? Doesn't seem normal, but the car feels fine and no lights on the dash. I don't want to destroy my car, so just wondering if I should flash back to stock before I drive back to work this afternoon?

Thanks!

Edit: I think to be on the safe side for now I'm going to load the stock file. Don't want to f anything up.
Can you log and see if you have any knock?
 

·
Registered
Joined
·
85 Posts
Ok easy fix. I thought the first tune was going to be for 87. It's actually for 91+. Loaded the stock file for now and will refill on 91 (probably 93 'cause 91 is less common around here now) and then re-flash.
 

·
Registered
Joined
·
1,996 Posts
Discussion Starter · #246 ·
I'm coming up on seven years with my car and will need to get smogged. I love my tune, but I turned off the erg valve on it, so I don't think it will pass, and my computer that had mazdaedit long since died.

I still have my tune files, but I'll need someone with deep editing capabilities to fully activate the erg valve. Who should I contact for that?

And will I have to buy another license of Mazdaedit for a new computer, or is there a way to transfer it over? If It's the former I may just pay somebody in socal to update it with their setup.
 

·
Registered
Joined
·
163 Posts
I have lost my tactix ob2 cable. Is there a replacement I can buy or is there other type of ob2 connection I can buy and still work with Mazda edit?

Sent from my Pixel 3 XL using Tapatalk
 

·
Registered
Joined
·
163 Posts
After getting my new cable it Mazdaedit is only saying it can't find ports when I try to connect to the ECU. Am I doing something wrong?

Sent from my Pixel 3 XL using Tapatalk
 

·
Registered
Joined
·
163 Posts
This is the brand new one I just got off Amazon OBD2 to USB on the computer

Sent from my Pixel 3 XL using Tapatalk
 
241 - 260 of 277 Posts
Top