Mazda 6 Forums banner

1 - 9 of 9 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
Hi everyone,
Just bought a 2020 GT. Speakers constantly buzz/static noise even with no music or audio on. It’s like electrical static constantly on and it gives me a headache! Mazda Brighton couldn’t fix it and said that all cars do it. Not sure if it’s a known fault or can be fixed. It’s so bad I’m thinking of selling the car because of it. Any advice/help would be appreciated. Cheers.
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #3 ·
Hi Dlav. Only bought it a few weeks ago as an ex dealer demo. So no aftermarket hardware. I’ve engaged Mazda Australia to tell me what my options are, as the dealer is saying it’s ‘normal.
 

·
Registered
Joined
·
21 Posts
Definitely not normal, i have a 2020 and my speakers were completely quite until i added a high power aftermarket amplifier. I believe the most common cause of your issue is a bad ground somewhere. Im not an expert but there are certain things you can do to troubleshoot. Is the sound constant or does it vary? Is the sound there when you turn the electronics on without starting the car? Is it a humm, hiss, or more or a whining sound? Answering those questions can help identify the cause.
 

·
Registered
Joined
·
21 Posts
Also, ive never heard of a demo car not having a warranty. Why wouldnt the Mazda factory warranty apply regardless? Makes me suspicious. The car might have had some kind of mishap. I friend of mine bought a dealer loaner car only to find out years later it had been in an accident. Even if so you still might have got a good deal. Every car i bought before my mazda 6 was used and had been in minor accident but i got great deals on them because of that and they all ran great.
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #6 ·
Hi Dlav. Really appreciate your interest and feedback. I suspect a grounding issue as well. The noise is constant and always present - engine on or off. Even in accessories mode on only with no engine, it’s there. It’s like hearing ‘white noise’. High frequency static like sound.
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #7 ·
I’ll continue to work with the dealer and Mazda Brighton to get it resolved. I guess I wanted to find out if it’s a normal characteristic or not.
 

·
Registered
Joined
·
21 Posts
Hi Dlav. Really appreciate your interest and feedback. I suspect a grounding issue as well. The noise is constant and always present - engine on or off. Even in accessories mode on only with no engine, it’s there. It’s like hearing ‘white noise’. High frequency static like sound.
No problem, good luck!
 

·
Registered
Joined
·
3,521 Posts
Hi Dlav. Really appreciate your interest and feedback. I suspect a grounding issue as well. The noise is constant and always present - engine on or off. Even in accessories mode on only with no engine, it’s there. It’s like hearing ‘white noise’. High frequency static like sound.
When the car is unlocked, the audio may still be active, is the volume all the way up?
 
1 - 9 of 9 Posts
Top