Mazda 6 Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1 (Edited)
Hey guys put a 2004 Mazda 3 SP23 Motor in my mazda 6 2006 2.3L and ive swapped every bolt on over apart from crank pulley and cam position and crank position sensor everything is plugged in just wont start turns over no worries sounds healthy checked for spark dont think theres anything is there any reason this motor wont start?
Edit:
Getting camshaft position sensor fault on obd2 scan
 

·
Rally Racer
Joined
·
3,308 Posts
Hey guys put a 2004 Mazda 3 SP23 Motor in my mazda 6 2006 2.3L and ive swapped every bolt on over apart from crank pulley and cam position and crank position sensor everything is plugged in just wont start turns over no worries sounds healthy checked for spark dont think theres anything is there any reason this motor wont start?
There are a lot of reasons why this could happen. You will need to systematically check through the various components for signal.
@Davids6 may have something to say about this as well. ;)
 

·
Registered
Joined
·
4 Posts
Discussion Starter #3
There are a lot of reasons why this could happen. You will need to systematically check through the various components for signal.
@Davids6 may have something to say about this as well. ;)
Yeah bud thats the plan just seeing if anyones done this swap before if the motor is even the same or timings different or if someones resolved the issue
 

·
Registered
Joined
·
38 Posts
If you remove your valve cover you will likely see that the timing cog changed from the earlier engine to the newer one. You need to swap these over and assuming everything else is okay you should be good to go.

Please read here:

 

·
Registered
Joined
·
38 Posts
If you remove your valve cover you will likely see that the timing cog changed from the earlier engine to the newer one. You need to swap these over and assuming everything else is okay you should be good to go.

Please read here:

And see this too:

 
1 - 5 of 5 Posts
Top