Mazda 6 Forums banner
1 - 6 of 6 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter · #1 ·
Has anyone changed a mass airflow sensor on a 2014 Mazda 6 skyactiv 2.2D 175PS?

So I have one, looks the same, same part number. I would have assumed it was plug and play - take two screws out, unplug old one, plug new one in, two screws in, start car, drive away.

So when I change for the new one it comes with up with faults. Tried unplugging battery to reset, still comes up with faults, put old one back in no faults! Do these have to be programmed to the car somehow?
Faults that show is SCBS / check engine. OBD shows fault for mass airflow open circuit.

Any advice or help would be appreciated.

Thanks
 

·
Registered
Joined
·
2,575 Posts
It's unfortunate that most members here have the gasoline variant. I have the diesel but I haven't done it yet as the car is relatively new.

@TalonTsi90 might have an idea and if it needs FORScan.
 

·
Registered
Joined
·
128 Posts
On the Gas motor MAF fail causes the car goes into limp mode then dies and will not start.
Happened to mine.
Threw codes for the TPS and throttle body. bought a used one, same dead car.
Was ready to have it towed to the Dealer. Called a local mechanic. He said buy a MAF as Mazda's might not show it in a scan. Found a aftermarket one on Ebay for under $30. Runs fine. bought a second and keep it in the trunk.
Two phillips screws and one connector, 10 min. change out.
 

·
Registered
2014 Sport NAV - Jet Black Diesel MT6
Joined
·
517 Posts
I take it you did reset all codes before fitting, start the car without the MAF connected, reset MIL again, connect MAF and start the car again?
 
1 - 6 of 6 Posts
Top