Mazda 6 Forums banner

1 - 16 of 16 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
I have a 2006 Mazda 6, went to leave for work yesterday morning & my low beam head lights didn't come on. The high beams works, as well as all other lights on the car. Changed the head lights & checked all fuses, seem to be good. I have no clue what the problem can be. Can anyone help me with this? I'd rather not have to take it to the dealership & pay $75 an hour if I can help it.
 

·
Registered
Joined
·
84 Posts
every bulb has a ground wire on it, check to see if you have any loose wires that connect to the low beam, it'll be its owe seprate wire
 

·
Registered
Joined
·
5 Posts
Discussion Starter #3
Thank you, I'll try that. I was also told that I could only replace the head light bulbs with factory bulbs I had to purchase at the Mazda dealership, that because I replaced the bulbs with ones I purchased from AutoZone, that is the reason they are not working. I'm not sure if I believe since, the owners manual also states they have to be replaced at the dealership, due to the complexity of it, I'm a woman and figured it out, thanks to directions I found on here. Feel they are just trying to get money out of me.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #5
Question is do I have to purchase the bulbs from Mazda directly? I was told they are still not working because I replaced them with bulbs I purchased from AutoZone. I don't see where I purchased them from making a difference & that being the reason they are not working.
 

·
Registered
Joined
·
658 Posts
Question is do I have to purchase the bulbs from Mazda directly? I was told they are still not working because I replaced them with bulbs I purchased from AutoZone. I don't see where I purchased them from making a difference & that being the reason they are not working.
it doesnt. dealerships just want to make money.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #8
That's what I thought also. Thank you. Do you know how to change the headlight switch? I can't seem to find directions on that anywhere
 

·
Registered
Joined
·
84 Posts
figured it was a loose wire, i had that problem when i switched my bulbs to aftermarket, doesn't take much to knock it loose
 
1 - 16 of 16 Posts
About this Discussion
15 Replies
9 Participants
Apl0215
Mazda 6 Forums
Mazda6club.com is a forum dedicated to the Mazda6 / Atenza. Come and discuss reliability, performance, modifications, and more!
Full Forum Listing
Top