Mazda 6 Forums banner

1 - 12 of 12 Posts

·
Registered
Joined
·
352 Posts
Discussion Starter #1
Like the title says I need advice picking an LOC and how to install it. I going to be installing an amp and sub to my stock system. There are many to choose from and have never bought one before. I also want to keep use of my rear speakers, so I don't want to cut any wires. I could use some of your expert advice on this.

BTW, I'm putting in an Orion 8002 for my 2 Alpine 10" R's. I bought Knukonceptz wires for the intstall as well.

Thanks!

Sam
 

·
Registered
Joined
·
352 Posts
Discussion Starter #3
Ok, but which one do I chose? There are a bunch of them and I don't know which one is right. I've also heard PAC is good, but again, I don't know what exactly to get.
 

·
Registered
Joined
·
352 Posts
Discussion Starter #4
N/m, I went to my local shop and they gave me a Lightning Audio LOC. I also tried getting the amp through them, but they couldn't come anywhere near Ikesound's price.
 

·
Registered
Joined
·
16 Posts
Slenser, your choice depends on the application.
I only wanted to tap and amplify the front channels (I also have a sub) so I got the NE-7V.

I originally purchased a Stinger LOC but that introduced so much noise it was terrible.
The David Navarone produces a nice clean signal.
 

·
Registered
Joined
·
2,932 Posts
how abt audiocontrol lc6? anybody uses them? are they good?
 

·
Registered
Joined
·
352 Posts
Discussion Starter #7
Well, I decided to do our Navigator first, so I'm using the Lightning Audio LOC for it. I'll see how it works. One good thing about buying local is the guy gave me wires and taps. I'm installing an elemantal Designs 8" in the stock location and replacing the stock Alpine amp with a Directed Audio 250D. So 500 Watts into 2 ohms :D
 

·
Registered
Joined
·
165 Posts
how abt audiocontrol lc6? anybody uses them? are they good?
[/b]
I'm using the LC6 and a EQS in my speed6. I tapped in before the bose amp and it sounds great. The signal coming off of the stock HU is extremely low, it will sound much better with a aftermarket HU with some decent voltage. But that's the best I can do for now. I have the EQS going to 2 JL 500/1's and a 300/4. The 500/1's are feeding a pair of 12W6V2's and the 300/4 is running Dynaudio components in the front doors and some diamond audio 5.25's in the rear.
 

·
Registered
Joined
·
352 Posts
Discussion Starter #9
I was wrong, it's not Lightning Audio, it's Stinger.

I'm now having problems with the bass. Virtually non-existant. The subs are so quiet, the other speakers drown them out. I don't know what the problem is. I hate this. I don't know if it's the LOC, the amp, or sub. GRRRRR
 

·
Registered
Joined
·
352 Posts
Discussion Starter #11
My 6 is non-bose. My problem install is my Navigator with factory Alpine.

To top it all off. One of the kids let my dog out yesterday, while I was working on the truck. I didn't even know he was out. I'm guessing with all the damn rabbits around he chased one and got himself lost. Now my dog is missing and the only tag on him right now is the rabbies with the vet's number on it. Unfortunately, they don't even have an answering maching and the pound is closed too!

OH YEAH! Lets not forget my youngest leaving a scooter behind my car so when I back up, I run it over and it scratches my 6! I had a very bad day yesterday.
 

·
Registered
Joined
·
215 Posts
My 6 is non-bose. My problem install is my Navigator with factory Alpine.

To top it all off. One of the kids let my dog out yesterday, while I was working on the truck. I didn't even know he was out. I'm guessing with all the damn rabbits around he chased one and got himself lost. Now my dog is missing and the only tag on him right now is the rabbies with the vet's number on it. Unfortunately, they don't even have an answering maching and the pound is closed too!

OH YEAH! Lets not forget my youngest leaving a scooter behind my car so when I back up, I run it over and it scratches my 6! I had a very bad day yesterday.
[/b]
I used the lc6 with my non bose and it sounded great. I cant compare it to a navone loc cus I never heard one but the SQ of my system with the lc6 was very similar to my aftermarket eclipse unit and provided 5 volts rms to my amps. Tap into front speakers as the man said. I have pics of my lc6 install in my sig. I def recommend the lc6 for your application.
 
1 - 12 of 12 Posts
About this Discussion
11 Replies
7 Participants
Tyroneshoes
Mazda 6 Forums
Mazda6club.com is a forum dedicated to the Mazda6 / Atenza. Come and discuss reliability, performance, modifications, and more!
Full Forum Listing
Top