Mazda 6 Forums banner
1 - 4 of 4 Posts

·
Registered
Joined
·
13 Posts
Discussion Starter · #1 ·
Morning!
Figured I’d ask here before forking over cash for a diagnosis (in case the solution is super simple):

I own a 2015 M6 iSport. Runs fine, no issue. Whenever someone gets out of the passenger side front and closes the door, the KWL beeps and starts flashing red. Sometimes it randomly goes away, but other times it continuously flashes until I shut the car off after reaching my destination. It’s not a battery issue because I’ve replaced the battery (and replaced the replacement just in case) of the FOB within the past two months. Granted, it’s been happening before that too. Only once after this happens has the car NOT started with the push button. Every other time, it starts up just fine. I’d say this happens maybe 8/10 times.

Thoughts?
 

·
Registered
Joined
·
6,811 Posts
After replacing the fob batteries, did you hold each one up to the Start button to reinitialize them? I had to do this back in March and just held each fob up to the Start button and pushed it with the FOB and no issues after.
 

·
Registered
Joined
·
13 Posts
Discussion Starter · #3 ·
After replacing the fob batteries, did you hold each one up to the Start button to reinitialize them? I had to do this back in March and just held each fob up to the Start button and pushed it with the FOB and no issues after.
No, I’ve never done that. Just switch out the batteries and the fob always worked, no issue. I would say the passenger door KWL issue started several months ago (maybe 6?7?). I’ve had the car since 2018 though.
 

·
Registered
Joined
·
3,282 Posts
I replaced the battery once and didn't do this initialization and besides, I don't remember reading that in the owner's manual. I might have missed it though.

I suggest removing the negative terminal for about 30 minutes if that initialization doesn't work.
 
1 - 4 of 4 Posts
Top