Mazda 6 Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Good morning! I have a 2004 Mazda 6 6cyl with about 75k miles on it. It's been running problem free up until this morning.

It's been extremely hot here the past week, and I noticed two days ago that my temperature display in the dash was not climbing past 70 (yes, it was set on Ambient Temp). I wasn't too worried, this happens sometimes when it's extremely hot, or extremely cold. (I have no idea if this is related to the following issue...)

This morning, however, as I got in to go to work, I put the key in the ignition, gave it about 3/4 of a turn, and just as the engine started to turn over, everything just went dead! I mean, it was sudden, not like the car tried slowly and painfully to start, everything just stopped short.

I took the key completely out of the ignition and watched as ALL the gauge needles in the dash started spinning and jumping around like the car was possessed! There were no warning lights or anything on, just the needles jumping. I closed the door to the car and they still jumped and the CD changer fired up, and I could hear it shifting through the cds. The radio was not on, and again, no warning lights at all. After about 30-40 seconds it stopped. I got out and walked away!

The demon car is still sitting in my garage (I had to get to work so I didn't have time to open the hood....not that I know what I would be looking for anyway). Does anyone have ANY idea what might cause this? With the hurricane hitting tomorrow, and it being a holiday weekend, there's no point in getting it to a shop until next week, and I do have another car I can drive. I'm just hoping it's something silly and not something expensive! Thanks in advance for any help!
 

·
Registered
Joined
·
781 Posts
battery is dead. time for a new one.
 
1 - 3 of 3 Posts
Top